Torrents not showing up in ruTorrent


#1

Hi,
rTorrent is working fine but my torrents are no longer showing up. I think I might’ve screwed up by modifying the rtorrent.rc configs while it was running.
I’ve been trying for 2 hours but just can’t bring it back to normal. Any idea?

Thanks for your help!


#2

Have you tried default rtorrent.rc settings?
Also try disabling rtorrent, restart server and enable rtorrent again


#3

I created a new rtorrent.rc based on the template found in /root/.bashrc, changing the necessary values like ports and user. I then restarted the server with rtorrent still disabled, re-enabled it and it still doesn’t show my torrents. My .sessions folder seems to be intact. I’m at lost.

Here’s the rtorrent.rc I made from the template:

scgi_port = localhost:45753
min_peers = 1
max_peers = 100
min_peers_seed = -1
max_peers_seed = -1
max_uploads = 100
download_rate = 0
upload_rate = 0
directory = /home/clusk/torrents/rtorrent
session = /home/clusk/.sessions/
schedule = watch_directory,5,5,load_start=/home/clusk/rwatch/*.torrent
schedule = filter_active,5,5,"view_filter = active,d.get_up_rate="
view_add = alert
view_sort_new = alert,less=d.get_message=
schedule = filter_alert,30,30,"view_filter = alert,d.get_message=; view_sort = alert"
port_range = 45753-47253
use_udp_trackers = yes
encryption = allow_incoming,try_outgoing,enable_retry
peer_exchange = no
check_hash = no
execute_nothrow=chmod,777,/home/clusk/.sessions/

When I try the rtorrent command logged-in as user, I get this message:
rtorrent: Error in option file: ~/.rtorrent.rc:2: Could not prepare socket for listening: Address already in use

I remember getting the same error last night, but I think at one point rtorrent didn’t give any errors but still didn’t show my torrents.


#4

Does your scgi_port in the .rtorrent.rc match the port listed in /srv/rutorrent/conf/users/USERNAME/config.php (at line 18)? Also, it looks like your missing some things from that. Here is a default you can adjust accordingly.

I already changed all the fields for you in the below paste…

# -- START HERE --
directory.default.set = /home/clusk/torrents/rtorrent
encoding.add = UTF-8
encryption = allow_incoming,try_outgoing,enable_retry
execute.nothrow = chmod,777,/home/clusk/.config/rpc.socket
execute.nothrow = chmod,777,/home/clusk/.sessions
network.port_random.set = yes
network.port_range.set = 45753-47253
network.scgi.open_port = localhost:45753
network.tos.set = throughput
pieces.hash.on_completion.set = no
protocol.pex.set = no
schedule = watch_directory,5,5,load.start=/home/clusk/rwatch/*.torrent
session.path.set = /home/clusk/.sessions/
throttle.global_down.max_rate.set = 0
throttle.global_up.max_rate.set = 0
throttle.max_peers.normal.set = 100
throttle.max_peers.seed.set = -1
throttle.max_uploads.global.set = 100
throttle.min_peers.normal.set = 1
throttle.min_peers.seed.set = -1
trackers.use_udp.set = yes
# -- END HERE --

#5

Thanks for your help.
So I checked and the port in config.php is 45753 so it’s the same. I disabled rtorrent, changed to config to the one you posted, rebooted the server and then restarted the service. Still no luck :frowning:


#6

Does la -al /home/clusk reveal any issues with permissions? Everything there should be owned by your username.


#7

Here’s what I get. A few things aren’t owned by my username.

*Edit: I just noticed an empty ~/torrents/rtorrent/.sessions/ folder that seems to have been created right when it stopped working. Weird since I never changed that setting. Could it be using that folder instead of the regular ~/.sessions/? (Edit: No idea where that came from but it doesn’t seem to be related after all)

*Edit 2: Still not working and I really don’t know what to try anymore. I spent so much time on this, I just need it fixed. Is there anyway I could have someone look at it @JMSolo ? I really need some help and I don’t mind paying of course.

drwxrwx---+  21 clusk plex    4096 Sep  6 01:21 .
drwxr-xr-x    3 root  root    4096 Sep  3 16:11 ..
drwxrwx---    2 clusk clusk   4096 Sep  3 16:28 .autodl
-rw-rw----    1 clusk clusk   8096 Sep  6 18:26 .bash_history
-rw-rw----    1 clusk clusk    220 Sep  3 16:26 .bash_logout
-rw-rw----    1 clusk clusk   4435 Sep  3 16:26 .bashrc
drwxrwx---    2 clusk clusk   4096 Sep  3 16:51 .cache
drwxrwxr-x    7 clusk clusk   4096 Sep  4 22:51 .config
-rwxrwx---    1 clusk clusk    730 Sep  3 16:51 .du.sh
drwxrwxr-x    2 clusk clusk   4096 Sep  5 22:30 .go
drwxrwxr-x    5 clusk clusk   4096 Sep  5 22:23 go_projects
drwxrwx---    3 clusk clusk   4096 Sep  3 17:41 .irssi
drwxrwxrwx    4 clusk clusk   4096 Sep  3 04:07 Jackett
drwxrwxrwx    8 clusk clusk   4096 Sep  4 22:40 Media
drwxrwx---    2 clusk clusk   4096 Sep  3 23:31 .nano
-rw-------    1 root  root       1 Sep  6 00:41 nano.save
-rw-------    1 root  root       1 Sep  6 00:41 nano.save.1
-rw-rw-r--    1 clusk clusk  12255 Sep  4 22:03 nodesource_setup.sh
drwxrwxr-x  275 clusk clusk  12288 Sep  4 21:44 .npm
-rw-rw----    1 clusk clusk    676 Sep  5 22:25 .profile
-rw-------    1 root  root    1024 Sep  5 22:43 .rnd
-rw-rw----    1 clusk clusk    855 Sep  6 18:32 .rtorrent.rc
drwxrwxrwx    2 clusk clusk  53248 Sep  5 23:20 rwatch
drwxrwxrwx    2 clusk clusk 815104 Sep  6 18:39 .sessions
drwxrwx---    2 clusk clusk   4096 Sep  3 22:28 .ssh
drwxrwx---    9 clusk clusk   4096 Sep  4 18:48 TheBlackBox
drwxrwxrwx    3 clusk clusk   4096 Sep  5 22:40 torrents
drwxr-xr-x    6 root  root    4096 Sep  6 00:49 varroa
drwxr-xr-x    3 clusk clusk   4096 Sep  6 00:36 varroa-downloads
drwxr-xr-x    2 clusk clusk   4096 Sep  6 00:27 varroa-ready
drwxr-xr-x    2 clusk clusk   4096 Sep  6 01:01 varroa-watch
-rw-r--r--    1 root  root     171 Sep  5 23:31 .wget-hsts

#8

Sure thing, I will swing you a PM the moment I have time to login to your server and figure this out. There are a couple of people in the queue at the moment, but we’re moving right along. :wink: I’ll be in touch shortly.


#9

Awesome, thanks a lot :slight_smile: I’ll wait for your PM.

Update: Haven’t made much progress since yesterday. I’m keeping rTorrent disabled for the time being and I’ll wait for your PM. Thanks!


#10

Still not working :frowning: Any idea when you’re gonna be able to help me @JMSolo ? I’m willing to pay 25$ to whoever can fix this.


#11

Apologies, got caught up in recent updates. I should be able to help you out later today.


#12

No problem, I understand. I’ll be online working all day so PM me when you can!

Update:
Ok so I did some experiments tonight and I think I found the cause, or at least the root of the issue. :confused:

First of all, rTorrent seems to be working fine but I still get the error (~/.rtorrent.rc:9: Could not prepare socket for listening: Address already in use) when I type rtorrent as a the user after starting the service from the dashboard. Is that command used to start rtorrent? Is it throwing me this error because rtorrent is already running and listening to the scgi port?

I decided to back-up my .sessions folder, delete everything, and start rtorrent. I added a torrent, looked at the .sessions folder and then it hit me.
Contrary to the new folder, my original .sessions contained only 2 types of file:
*.torrent.libtorrent_resume
*.torrent.rtorrent

No *.torrent in sight. I’m kinda kicking myself for not noticing that earlier.
So that seems to be the reason why rtorrent isn’t loading them up… but why did they disappear? Is it possible with a misconfiguration? How can I make sure that doesn’t happen again?

Now I have the hashed libtorrent_resume/rtorrent files and the originals .torrent.
Is it possible to somehow fix this or should I just forget it and re-import my 2k+ torrents from scratch? I normally wouldn’t mind but the files are spread across multiple folders so I’d have to add torrents in a paused state and re-associate all of them.