Thumbnail creation takes too long time


#1

Hello,

I downloaded a test torrent of a video file and tried creating its image sheet. It seems that ffmpeg is taking too long time for creating a single Thumbnail. (It took me 100-110 seconds) (My server is E3-SAT 2 on SoYouStart with only 1 torrent in seedbox).

Also the size of generated Image Sheet was 1.5-2 MB. I think it should be between 250-600 KB.

I have tried creating screenshots by this tool : http://moviethumbnail.sourceforge.net/
But it was via SSH, and it took 3-4 seconds. and the size of image was 450 KB.

Guys I am not at all complaining about the script This script is wonderful, and to see it freely available with such a great community and support is superb.

Thanks & warm regards.


#2

have you played with the file manager screenshot settings?


#3

After installation I took the Screenshot without changing any settings. Later on I did change the row to 3 and column to 9. Yes it reduced the file size and few seconds too. But not that much though.

With the above mentioned tool (Movie Thumbnail) it takes 3-5 seconds and for the same image quality and same rows and columns. Also the size of image was 450 KB which in comparison to 2.5 MB is too less.


#4

if we could find someone to take the time to develop a plugin or dock app gui might be an idea.

though i will say the tools used for the link you shared is what make the screenshots work already so it’s really just settings and quality i think the moviethumbnailer might be cutting some of the quality out
I have not tried it so i do not know.


#5

The culprit here is mostly ffmpeg. I’m not sure how much of this is quickbox vs your cpu etc…

I’ve pushed a commit to the v2.3.8 branch that expands the ffmpeg compile options. Perhaps this will help.


#6

i did one previously with my m2ts configured box and it took maybe 20-30 seconds with the fact this was a 33 gb file