This server requires a certificate to validate your identity


#1

Fresh install and went to login via ftp and got the error in the title with Cyberduck.


#2

This is normal under most circumstances. It is simply your remote access to a computer asking if you trust it. This happens due to the server not having a validated certificate. It’s a normal harmless warning, like the other 10 million popups in Windows and various other applications. :slight_smile: