Tautulli link not working from dashboard - Community version

ubuntu
16.04
dashboard
tautulli

#1

Hello fellow Quickboxers,

I’ve updated my QB to 2.5.5 recently and discovered that there was, among others, a new package called Tautulli.

Since I’m using Plex, I’ve installed it from the dashboard but it’s not working, I get a “can’t find this webpage” type of error. I had a look at that WIKI page but it did not solve my problem.

Is this a known problem?

Here is my default Tautulli.conf:

<Location /tautulli>
ProxyPass http://localhost:8181/tautulli
ProxyPassReverse http://localhost:8181/tautulli
#AuthType Digest
#AuthName "rutorrent"
#AuthUserFile '/etc/htpasswd'
#Require user MyUserName
</Location>

Which I’ve changed to:

<Location /tautulli>
ProxyPass http://localhost:8181/tautulli
ProxyPassReverse http://localhost:8181/tautulli
Require all granted
</Location>

But to no avail.

I then replaced localhost with the server FQDN, but I got a 503 error. I eventually tried with my IP address and also got a 503 service unavailable error…

Thank you for your help and guidance!


#2

I’ve tried again this weekend but I could not find any solution.

Has anyone else has this issue?


#3

In addition to the edit to /etc/apache2/sites-enabled/Tautulli.conf and restarting apache2 service
noted above, I got mine to work by setting the HTTP Host to 127.0.0.1 or 0.0.0.0 instead of localhost in the Settings>Web Interface of Tautulli. Since my quickbox is a VPS, I had to use Putty SSL tunneling of port 8181 in order to edit it in the GUI, but you can also just manually edit it in /opt/Tautulli/config.ini by editing the line value under General to http_host = 127.0.0.1 then restart Tautulli.