Syncthing reverse proxy - 500 Internal server error

syncthing
reverseproxy

#1

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

I can get to syncthing webui using the ipaddress and corresponding port or using a ssh tunnel but that’s pretty much the same thing. I also didnt find anything relevant in /var/log/apache2/error.log


#2

I just installed syncthing for the first time(just to test your issue) on quickbox and I didnt have this issue. I was able to go to https://server/syncthing and didnt have any issues. I got the normal synthing config menu where I selected a folder to sync, etc.

I wonder if its an issue with having syncthing configured before the switch?


#3

Just tried uninstalling/reinstalling syncthing. As well as deleting the syncthing folder located in ~/.config. Now getting connection refused when using https://mydomain.com/syncthing as well as when trying https://myipaddress:8384. SSH tunnel to 8384 still works though.

Just to confirm default syncthing listening address is localhost:8384 correct? That is what shows up when I go to the WEBUI settings console.

systemctl status [email protected] shows
hostname:/home/username/.config# rm -rf syncthing/
hostname:/home/username/.config# installpackage-syncthing
hostname:/home/username/.config# systemctl status [email protected]
[email protected] - Syncthing - Open Source Continuous File Synchronization for username
Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
Active: active (running) since Sat 2016-10-08 22:26:55 CEST; 11s ago
Docs: man:syncthing(1)
Main PID: 27404 (syncthing)
CGroup: /system.slice/system-syncthing.slice/[email protected]
└─27404 /usr/bin/syncthing -no-browser -no-restart -logflags=0

Oct 08 22:26:56 hostname syncthing[27404]: [AKYDC] INFO: GUI and API listening on 127.0.0.1:8384


#4

the only problem i had was after purging it and reinstalling it, was that if you set a password or change any major settings that mess with the apache authentication it will kill the gui but program stays running.


#5

Thanks! Reverse proxy link is working from the quickbox dashboard.I did not test functionality beyond this though.

I did the following:

apt-get purge syncthing
apt autoremove (not sure if this was necessary, but I did it anyway)
rm -rf ~/.config/syncthing/
installpackage-syncthing