Syncthing not accessable


#1

Hi there

read through the posts about Syncthing but not really able to get anywhere.

It wont let me access the site anymore, just popping a username / pass.
Once I enter the credentials and yes the credentials are correct as I used them so many times now.
Once typed another login pops as the dashboard is now frozen and only usable again after login.
Tried a few times to uninstall and reinstall via dashboard but nothing helps same situation.
Also tried a apt-get purge --auto-remove syncthing ect.

So any suggestion to what can be done so that it will let me use syncthing? And not loop some login popups!

It is running on a Deb 8 system.


#2

Tried reinstalling and uninstalling via dashboard.
Even though it says that configuration is set back to default access to url is not…still being asked for a user/pass!

Tried apt-get purge syncthing to see if the uninstall process was missing some configuration files or something like that.
Tried a reinstall and still need to put in a username and password to access…

Ending up with it not being accesseble:

Is there something I have missed somewhere…a configuration telling it to use a username/password? That needs to be deleted/changed!


#3

/etc/apache2/sites-enabled/syncthing.conf

Remove:

AuthType Digest
AuthName "rutorrent"
AuthUserFile '/etc/htpasswd'
Require user USERNAME

Instead of these lines, you can add Require all granted

Thus your syncthing.conf would look like

<Location /syncthing>
ProxyPass http://localhost:8384
ProxyPassReverse http://localhost:8384
#AuthType Digest
#AuthName "rutorrent"
#AuthUserFile '/etc/htpasswd'
#Require user USERNAME
Require all granted
</Location>

Then restart apache. You may additionally have to clear out your browser cache as well.


#4

Boom did it - thanks a lot :slight_smile: