SSH in Lshell bug

lshell
multiuser
ssh

#1

When connecting to a server running lshell you type ? and it spits out all the usernames on the server in a multiuser environment.


#2

yeah, its a known issue…I flagged that several months ago. I dont see a way to address it.


#3

Ok…so I upgraded lshell with this: http://ftp.de.debian.org/debian/pool/main/l/lshell/lshell_0.9.18-2_all.deb

It errors on the QB lshell.conf file but if you put in the package maintainer conf file then it doesnt error.
The ‘?’ now doesnt show the users:

You are in a limited shell.
Type ‘?’ or ‘help’ to get the list of allowed commands
rick:~$ ?
cd clear echo exit help history ll lpath ls lsudo

Edit: I found the culprit. This is what is causing it:
allowed_cmd_path: ['/home/']

Comment out that line and it fixes the issue. I found it by updating the package maintainers conf file with the QB settings and the users started showing up again…I’m like…WTF.

Edit 2: This is what was is causing issues with the newer lshell:
home_path : ‘/home/%u’

It didnt like the % symbol there.


Dredded lshell on secondary accounts
#4

Yea I’ve been fiddling around as well trying to see if I can find where the heck it’s doing that. It’s a pain in the ass.