Sonarr - Unable to connect to indexer, check the log for more details

Well, the 401 error in Sonarr strictly implies that credentials are wrong somewhere. This is more than likely due to Sonarr not accepting the proxy Jackett. For the host field enter it as:

Where XXXX is the port found in /etc/apache2/sites-enabled/jackett.conf and INDEXER is the site you are wrapping with Jackett


check your jacket credentials + api key in sonarr.

Im not sure if its just me but Jackett seems to have some issues on my end from time to time (crashing)

The API key is the correct one, the main reason for your Jackett is crashing is because you need to update it (run a check for update in Jackett and then run the upgradeJackett as root though the web console in the quickbox dashboard)

Its updated but it usually just stops after 2-3 days. I have started using Nyaa instead of AB for airing releases anyway so it doesnt matter too much.

I’m following you in that one, and i know that it’s somehow Sonarr that don’t accept the credentials that have been setup for Jackett, but the problem started after my suders file got wiped during an update (i updated the quickbox script though the deskboard of quickbox and had to get my sudoers file rebuild in order to get the script back in working order), nothing else than the suders file have been rebuild on my server, but someone the connection between Sonarr and Jackett got lost after the sudoers file got wiped.

My jackett.conf looks like this (the real username have been replaced with “username” since i don’t want to exploit my credentials online :wink: ):

<Location /jackett>
ProxyPass http://localhost:9117/jackett
ProxyPassReverse http://localhost:9117/jackett
AuthType Digest
AuthName "rutorrent"
AuthUserFile '/etc/htpasswd’
Require user username

Sure, ok… now in the host field in Sonarr…
I guess I should call that the URL field instead, apologies if I was confusing there.

1 Like

The host (URL) for sonarr is: https://ip-address-to-the-server/jackett/torznab/xxxxxxxx (the ip isn’t localhost, since my server isn’t located locally), and i have tried both with http:// and https:// and the result is the same. Have also tried to login to my server and tried to add the site to Sonarr that way (by using localhost) but got the same failure

You’re not the only one with this problem @wizard
Have tried the last 2 days to get Jackett and Sonarr working, but without results :frowning:

No, I think if you are not willing to attempt my solution then there really isn’t a whole lot I can do for you. localhost is the address of every webserver. It’s localhost… as in (this computer). When I suggest that you try something exactly as stated, I am genuinely implying… “Do exactly this method and see if it works”.

I think this is related to Jackett being behind the password protected reverse proxy. My guess is if you remove the password protection that it would work.

HTTP Error - Res: [GET] https://localhost/jackett/torznab/alpharatio/api?t=tvsearch&cat=5030,5040&extended=1&apikey=(removed)&offset=0&limit=100: 401.Unauthorized

401 Unauthorized


This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

Apache/2.4.18 (Ubuntu) Server at localhost Port 443 Close

It is, that is why http://localhost:9117/yadayadayada is required. It needs the http port specified.

yep…that worked for me…just tried it.

I appreciate you tremendously for verifying that for me @RXWatcher! Seriously!

I just applied the same to @Titte95’s server and it’s communicating as well. The proxy is hounding the connection so it needs semantics.

Can confirm that if you use @JMSolo solution here - Sonarr and jackett is working just fine.
Thanks JM for helping me out!

Hello guys, I have the same problem but manually specifying the port still doesn’t work for me. The server actively refuses connections on the jackett port (9117). Can anyone help? Thanks!

EDIT: nevermind, a reboot fixed it! :slight_smile:


I’m a bit confused… How do I remove the password protection from the reverse proxy exactly?

I’m having a similar issue and even with http://localhost:9117 used as my connection in sonarr it still refuses connection to jacket here’s an example


@maddawg2 was able to fix it via uninstalling Jackett, removing the ~/Jackett/ directory and reinstalling.

When you go into Jackett and copy the URL, does it contain a hostname or is it an IP? In @maddawg2’s case it was an IP.

I think that there is a thing when Jackett installs that it binds to the hostname via /etc/hosts and if thats off then it binds to an IP and if it’s an IP then the localhost doesnt work.

Yes it is an ip I’ll try reinstallling when I get home from work