Sonarr not working. No link and red icon


#1

Hi there,

Amazing piece of software you got here. I am a complete newb but have been learning lots over the last couple days.
I have had issues with Plex and learning how to link CouchPotato to Rtorrent. Been tons of fun.

I am however having an issue that I have search for an cannot solve.

Sonarr is not on the menu and has a red dot next to it.
Folowed someone elses issue with it but mine was a little different. Only Sonarr has a red dot.
I am on Kimsufi but did change the kernel at the start.

THISISME:~# systemctl status [email protected]
[email protected] - nzbdrone
Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset:
Active: inactive (dead) since Sat 2016-10-22 15:30:06 CEST; 6min ago
Main PID: 11094 (code=exited, status=0/SUCCESS)

Oct 22 15:30:06 THEDOMAIN systemd[1]: Starting nzbdrone…
Oct 22 15:30:06 THEDOMAIN systemd[1]: Started nzbdrone.

murica:~# sudo service apache2 restart

All this code I found on the forums and used it in Putty. These were the outputs.

Still is red and cannot access it.

Please remember I am a complete newb and thanks again for everything you are doing.


#2

Sonarr and Jackett both have these very finicky behaviors that are random at best.

Type in systemctl restart sonarr and see if that gets you back online. Additionally, some have reported that dependencies on the server needed to be updated, so you can type apt -y update && apt -y upgrade. QuickBox is built with current dependencies in mind, therefore updating the OS is encouraged and should cause no ill effects.

Let me know if the issue persist and we will look further into the issue.


#3

I ran the first part and got this Failed to restart sonarr.service: Unit sonarr.service not found.
Then ran update and upgrade.
Same error
THISISME:~# systemctl restart sonarr
Failed to restart sonarr.service: Unit sonarr.service not found.

Side note. On your site I get a 405 error on the PayPal return to merchant after donation. :slight_smile:


#4

Check out this thread and see if any of it helps your query… also I fudged the command for sonarr status, you can check it with systemctl status [email protected]

Here’s the thread:

If you have burned through that thread, have you additionally done an apt-get -y update && apt-get -y upgrade?

Well first off, thank you tremendously for showing some love for QuickBox! Second, I will look into this as soon as possible. It’s probably temporary POST errors with the PayPal API… which is always reliable (/end sarcasm)


#5

This is the output for systemctl status [email protected] (in which I replace USERNAME with my username for the dashboard, I assume)

THISISME:~# systemctl status [email protected]
[email protected] - nzbdrone
Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset:
Active: inactive (dead) since Sat 2016-10-22 15:38:05 CEST; 4h 33min ago
Process: 16375 ExecStop=/bin/kill -HUP (code=exited, status=1/FAILURE)
Process: 16364 ExecStart=/usr/bin/screen -f -a -d -m -S nzbdrone mono /opt/Nzb
Main PID: 16366 (code=exited, status=0/SUCCESS)

Oct 22 15:38:05 DOMAIN systemd[1]: Starting nzbdrone…
Oct 22 15:38:05 DOMAIN systemd[1]: Started nzbdrone.
Oct 22 15:38:05 DOMAIN kill[16375]: kill: invalid argument H
Oct 22 15:38:05 DOMAIN kill[16375]: Usage:
Oct 22 15:38:05 DOMAIN kill[16375]: kill [options] […]

I went through that thread before starting this one. The only red I have is for Sonarr
I did change the kernel upon install on my kimsufi box.
The .lock file is present.
Server:
Linux DOMAIN 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Also just rebooted the machine using sudo reboot. Still not solved.

Just doing some more checking and [email protected] is present.
-rw-r–r-- 1 root root 284 Oct 22 15:29 [email protected] in

This is what it has
[Unit]
Description=nzbdrone
After=syslog.target network.target

[Service]
Type=forking
KillMode=process
User=%I
ExecStart=/usr/bin/screen -f -a -d -m -S nzbdrone mono /opt/NzbDrone/NzbDrone.exe
ExecStop=-/bin/kill -HUP
WorkingDirectory=/home/%I/

[Install]
WantedBy=multi-user.target


#6

I really really am dying to know if you did this yet. :slight_smile:


#7

I did the update and upgrade earlier.


#8

0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.


#9

Hmm.

What happens if you do the following:

username=YOURUSERNAMEHERE
systemctl enable [email protected]${username}
systemctl start [email protected]${username}

#10

Hmmm

Maybe I have the wrong username or something.

Failed to start [email protected]: Unit name [email protected] is not valid.
See system logs and ‘systemctl status [email protected]’ for details.

I have been using the same one as I use to login to quickbox (not root) and FTP, couchpotato and the others

The enable gave no error.


#11

If you like, feel free to shoot me a PM and I can check on this issue first hand?

###Update

Thank you again @Shawn for allowing me to login to your server to check this out.

The issue is with CSF installed it was blocking legitimate traffic to the Ubuntu keyserver, therefore the keys needing to be imported for signing the packages were not… and this resulted in nzbdrone failing to install. Temporarily turning off CSF with csf -x and then running the key import once more successfully added the keys and allowed the nzbdrone package to be installed… and ultimately a working Sonarr.

I will look into white-listing the traffic needed for those keys tonight and adding them in an update to the CSF templates.


#12

My Sonarr was working fine and I suddenly am now having this issue. What is the exact resolution?