Sonarr HTTP Auth


#1

Hi,

Something has gone wrong with my sonarr installation and I cannot fix it. For some reason the HTTP authentication window that pops up when logging into quickbox dashboard, also pops up when loading the sonarr page (in a new window). My username and password do not work for this.

Strangely when closing this new tab for sonarr, the quickbox dashboard page now has the same popup and will not take my password. This continues until I close the browser and clear all my cookies and history.

I have no authentication enabled on sonarr and I have even verified this in the config.xml (authentication is set to none).

I have tried uninstalling sonarr, doing box upgrade command, shutting down the server, then installing sonarr again. I have tried installing from the dashboard and via the command line but each time it still puts me into this HTTP Authentication loop.

Can anyone help with this?
Thanks.


#2

You can remove those auth fields within the sonarr.conf file located at /etc/apache2/sites-enabled/sonarr.conf.

Change this

<Location /sonarr>
ProxyPass http://localhost:8989/sonarr
ProxyPassReverse http://localhost:8989/sonarr
AuthType Digest
AuthName "rutorrent"
AuthUserFile '/etc/htpasswd'
Require user ${username}
</Location>

To this

<Location /sonarr>
ProxyPass http://localhost:8989/sonarr
ProxyPassReverse http://localhost:8989/sonarr
Require all granted
</Location>

Then follow it up by restarting apache with sudo service apache2 restart

You may have to flush your browser cache once more.

This is more than likely something to be updated soon. As in applications with their own auth methods will be left alone from the htpasswd auth file.


#3

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.