Sonarr doesn't appear (red)


#1

Hi,

I just made a clean install of Quickbox. I wanted to install Sonarr but it remains red and no link appears.

I also tried via sudo box install sonarr, it did not find config.xml, I created an empty file, but still nothing.

If someone knows if a forgot something.

Thanks


#2

I have successfully installed sonarr but when I run I have Service Unavailable and I have these error messages when installing via box isntall sonarr

Installing sonarr

sed: can’t read /home/plex/.config/NzbDrone/config.xml: No such file or directory
sed: can’t read /home/plex/.config/NzbDrone/config.xml: No such file or directory

Thanks!


#3

You have a user named plex it would seem. I can promise you right off the start, that is going to cause conflict the moment you want to use Plex…


#4

lol yep ran into that with 2 people now LOL


#5

Yeah, it’s a massive “no no”. I’ll clear this up a bit more so people understand why this happens.

Since we’re on the subject of Sonarr, I will use that in this simple example.

The service Sonarr runs on your dashboard. The process shows as active by checking that the process exist, either under the services name (example, Plex process runs under the user created by Plex, which is plex) The Sonarr service checks that the Sonarr/nzbdrone processes are running as your username. So it will check as the following (you can find this in your /srv/rutorrent/home/inc/config.php file)

$sonarr = processExists("nzbdrone",$username);

When you run this service as username plex for instance, what this does is it checks the processes as

$sonarr = processExists("nzbdrone",plex);

Sonarr is smart enough to know that’s simply not right as another service requires this name to run. Thus it fails as it is struggling with the logic that another service is attempting to run it’s processes. This could also cause conflict with it’s initial installation.

It’s a common misconception that one would need to make a user named plex to have certain privileges for running Plex on your server. I would advise a new username to address this issue.


#6

I create another username and solve the problem

Thanks!