Sonarr Config Location


#1

Hey guys, loving my server, but sonarr crashed on me the other day. I removed and reinstalled it, but now it wants login credentials. Im digging everywhere i can think of to find the sonarr config to remove the required cred option to reset it, but have had no luck. Any help is appreciated!


#2

This should be in /home/USERNAME/.config/NzbDrone/config.xml


#3

Thanks Mischief, the file is there, however its set to “none” so not sure why its wanting a login from me… so frustrated that I’mScreenshot_20190304-175232_JuiceSSH locked out…


#4

If this is on Pro then it could be the Nginx Auth, you’d need to disable the authentication via the Nginx Options on the Sonarr Panel.

If this is on Community, it’s the Apache auth. You’d need to load up /etc/apache2/sites-enabled/sonarr.conf (I think, it’s been a while!) and disable the auth there. You could then enable form login in Sonarr to circumvent the issue


#5

Its community, Ill take a look at the apache config and see what i can find, pretty sure Ive looked at that file already.


#6

Got the file, Ive edited this before and it seems to break the gui from loading the main quickbox.io site. Ideas?
Screenshot_20190304-191834_JuiceSSH


#7

Can you trying putting a # in front of the lines that being with Auth, then running:

service apache2 restart


#8

Done. Still the same result. Screenshot_20190305-075203_JuiceSSH


#9

Had to wipe the os and reinstall. No fix found.