Some issues after installing QuickBox 2.4.6


#1

I’ve installed QuickBox 2.4.6 but have hit a few minor problems.

  1. When trying to add a user for sudo with visudo it appears the file is damaged, moving around the file shows characters that were not visible and the cursor jumps around to random locations (https://gyazo.com/12251453fce7dbe44ee6947ca6b75433)

  2. Changing the download and watch folder in rutorrent doesn’t seem to change it in .rtorrent.rc. The rutorrent interface shows the new locations but .rtorrent.rc shows the old locations.

  3. The QuickBox Dashboard shows no stats for bandwidth, server load etc (https://gyazo.com/7bb1b61afdb98c50f1f12058bc116e1a)

  4. Opening the Dashboard causes rutorrent to repeatedly request logon information even tho the credentials are correct. Closing the dashboard resolves this.

  5. Using Chrome doesn’t show the rutorrent interface correctly (https://gyazo.com/c156f7caa6f29cb029a476571c35bf68)

Any help would be appreciated.


#2

What does uname -a show?


#3

uname -a gives

Linux localhost 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2+deb8u3 (2016-07-02) x86_64 GNU/Linux


#4

This sounds like a client side issue. What ssh client are you using?

This has nothing to do with QuickBox. This is the intended behavior. If you want settings to persist across sessions, modify .rtorrent.rc - apache does not (nor should it) have write permissions to your home directory.

Your interface is probably not set run the command set_interface as root

Probably some cache issue. sudo service apache2 restart

This is the mobile interface - do you have any settings set in chrome that might cause rutorrent to think your client is mobile?


#5
  1. Client is SecureCRT and the problem didn’t happen prior to installing QuickBox
  2. Thanks, will do that
  3. running set_interface as root had no effect.
  4. restarting apache2 had no effect.
  5. Nothing is set in Chrome to make it think its a mobile client and it only happens in QuickBox

Is there a simple method to remove QuickBox?


#6

Try real quick to run box upgrade and see if this addresses some of your issues.

I can positively say without a doubt that none of this is related to QuickBox as none of these issues have ever cropped up. I am wondering if you are possibly running an encrypted filesystem as I have seen one other instance these types of issues and it was all due to the encryption used on the drive. it was simply a test by another user to verify a certain level of encryption.

In regards to the Mobile plugin being fired on entry, that plugin only fires if it reads a certain header scheme, usually belonging to mobile devices, ie; plugin.tabletsDetect. You could try to disable the ipad plugin in your plugins menu on the dashboard (if that is there, as if it is not… then your sudoer is borked).

What does the result of cat /srv/rutorrent/home/db/interface.txt show?


#7

The upgrade ran with no issues but hasn’t effected the problems and disabling the ipad plugin doesn’t seem to have changed the rutorrent interface in Chrome.

I’ve tried QuickBox on a couple of my home pc’s and on some VM’s and never had an issue with it so it may well be related to the box I’ve installed it on.


#8

The plugin is “mobile” rather than “ipad”

What host are you using? These are rather curious issues


#9

Thanks liara, that resolved the Chrome issue (yay!)

The box is a SuperSeedbox.com 12tb dedi, I haven’t used them before but a friend recommended them.


#10

That is especially curious that a common command isn’t returning any results.

####Shot in the dark:
Are there files in the /srv/rutorrent/home/widget directory?

…and the disabling of ipad and keeping mobile to confirm if there was a conflict as the two are not compatible. Glad that at least removing mobile has solved it… but it is indeed interesting that it is reading your browser as a tablet.


#11

/srv/rutorrent/home/widgets does contain files

[quote]bw_tables.php cpu.php lang_select.php plugin_data.php service_restart.php sys_data.php
class.php data.php load.php ram_stats.php shout.sql up.php
cpu_meter.php disk_data.php package_data.php service_enable-disable.php stat.php vnstat.php
203/16076MB 0.10 0.10 0.13 1/217 3045 [/quote]


#12

I am wondering if this is something to do with the host machine. If you are willing to, shoot me a PM with your login credentials and I can take a look firsthand and see if there is anything I can do to solve this.


#13

I’m wondering the same, PM sent, thanks!

Thinking of getting the host to reinstall the OS (I don’t have access to) and seeing what happens.

Tried MobaXterm instead of SecureCRT and the sudoers file is readable so you were right again. Never had a problem with SecureCRT in years, live and learn. Changed the SecureCRT emulation and its good again.

Thanks for all the help guys, it’s really appreciated.

By the way, does QuickBox block users from accessing commands somehow? Users are unable to access basic commands such as ps

dv9:~$ ps *** forbidden command: ps


#14

We restrict commands of the sub users by using lshell. You can either edit lshell.conf (/etc/lshell.conf I believe) or change the sub user to use /bin/bash as their shell in /etc/passwd

We do this for security purposes however, so please make sure if there are other users on the box beside you and you give them a bash prompt that they are personally trusted by you


#15

Thanks, the box is for my own use, it’s just that I required multiple users so the security precautions aren’t required in this instance.

Again thanks for all the help!