[Solved] - Cannot connect with SSH after a fresh install

ssh
install
ubuntu

#1

Hi Guys,

I am a bit stuck here. I have a dedi with Online.net (quite some time already) and decided to change its purpose into a seedbox, on QuickBox (paid for QuickBox Pro but that’s another story, want to try now the Community Edition).

The OS is Ubuntu 16.04, the installation is finishing with no (visible) errors. Then, when I restart the box and trying to connect to 4747 as a port, I am getting “connection timed out”. Connecting on port 22 gets me “connection refused” straight away (rightfully so as I could see the rule in iptables). I am following the steps to the letter (it is not that hard to copy-paste the script) but I am already on my 6th time reinstalling the OS and QuickBox and with the same effect. I have checked the sshd conf fine and it is properly changed there, I’ve explicitly allowed connection to 4747 in iptables (persistent),

I am reinstalling the OS again now as we speak, so don’t have the log files at hand, though I would be happy to try get it to work, if you have any suggestions or at least point me in a right direction. Any help will be appreciated, thanks in advance!


#2

When you say change do you then mean a complete reinstall of os or just changed an existing os to be able to run the installer?
I have done countless installs and never really experienced problems getting in contact via ssh…but this is usually on a fresh server. If your trying on a “changed” server do you have any leftover firewall rules running towards port 4747 or something is not listening right on port 4747 maybe.

Maybe something like - ```
netstat -pnlt | grep ‘:4747’


#3

Hi Globber, thanks for the message. I meant complete OS reinstall (fresh fron Online net console). Though now, I think that the issue doesn’t lie with QuickBox, most likely some ports are blocked on the router here in the office. I’ve got the list of open ports and will try it once again. It would be awesome if the script contained a variable where I could specify the SSH and FTP ports.


#4

yeah, so it was the office router blocking port 4747. To solve this, I haven’t restarted right after the script completed and went to change the SSH port manually and restarted the service. After tested the connectivity and it worked.


#5

lovely great you got it solved :smile: