[Solved] 503 Service unavailable on most packages

sonarr
sabnzbd
plex
install
ubuntu

#1

I have been struggling with getting quickbox packages working. So far I have been only successful in getting plex working. Every other package seems to install correctly but opening them up in the browser, I get a “503 service unavailable” message. This is a proxmox container running ubuntu 16.04

Here is the service status message when i try to install sabnzbd and sonarr:

sudo systemctl status [email protected]
[email protected] - sabnzbd
Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
Active: active (running) since Sun 2018-05-27 21:23:56 UTC; 14min ago
Main PID: 2877 (screen)
CGroup: /system.slice/system-sabnzbd.slice/[email protected]
├─2877 /usr/bin/SCREEN -f -a -d -m -S sabnzbd python SABnzbd/SABnzbd.py --browser 0 --server 127.0.0.1:65080 --https 65443
└─2888 python SABnzbd/SABnzbd.py --browser 0 --server 127.0.0.1:65080 --https 65443

May 27 21:23:56 media systemd[1]: Starting sabnzbd…
May 27 21:23:56 media systemd[1]: Started sabnzbd.

sudo systemctl status [email protected]
[email protected] - nzbdrone
Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
Active: active (running) since Sun 2018-05-27 21:36:34 UTC; 1min 35s ago
Process: 28459 ExecStop=/bin/kill -HUP (code=exited, status=0/SUCCESS)
Process: 28508 ExecStart=/usr/bin/screen -f -a -d -m -S nzbdrone mono /opt/NzbDrone/NzbDrone.exe (code=exited, status=0/SUCCESS)
Main PID: 28514 (screen)
CGroup: /system.slice/system-sonarr.slice/[email protected]
├─28514 /usr/bin/SCREEN -f -a -d -m -S nzbdrone mono /opt/NzbDrone/NzbDrone.exe
└─28515 mono /opt/NzbDrone/NzbDrone.exe

May 27 21:36:34 media systemd[1]: Starting nzbdrone…
May 27 21:36:34 media systemd[1]: Started nzbdrone.


#2

Issue fixed.

I suspect the problem was with me setting up a (different) static IP for the container “after” i installed Quickbox. So Quickbox was using the original dynamic IP address to install the packages.

There is probably an easy place to check/update this IP value, but reversing the steps fixed my issue.