Sickrage wont find new shows


#1

I have been trying to get sickrage working again but for some reason when I go to add shows it just times out and adds nothing, I have reinstalled , refreshed , preyed none working. I still have my old setup and it work fine there and finds shows in seconds.

searching holy on All Indexers in en… (always fails) forgot to add tried deleting cache.db file, also changed the timeout in settings

thanks


#2

You checked the log at all for any potential errors?


#3

I get this from the log…

2016-09-05 03:51:02 INFO SHOWUPDATER :: Could not get the recently updated show data from theTVDB. Retrying later. Url was: http://thetvdb.com/api/Updates.php?type=series&time=978303600 2016-09-05 03:51:02 INFO SHOWUPDATER :: Request failed: HTTPConnectionPool(host=‘thetvdb.com’, port=80): Read timed out. (read timeout=30) 2016-09-05 03:49:29 INFO CHECKVERSION :: Checking for updates using GIT


#4

The guys at sickrage has said I am on an old database, I have tried updating but it says no update available so it must be on the quickbox console itself…
’‘
Seeing as your log says 43.1 and our db is v44 it looks like something is wrong with updating there. Try a manual git pull’’


#5

It’s possible you have faulty permissions. I am able to update a QuickBox machine with SickRage installed that is around 4 months old and the following is the Configuration info:

SickRage Info:
Branch: master
Commit: 8564c29aa3b2d95bf41e03eed7e5a6938f1a6b3a
Version: 2016.09.03-1
Database Version: 44.0

This assures us that updates are working as expected on QuickBox installations.

Please verify that you haven’t adjusted permissions on your /home/USERNAME/.sickrage directory. Otherwise, these types of complications may arise, which are in summary, of no fault of QuickBox.

For clarity, permissions should be set as follows:

drwxr-xr-x  USERNAME.USERNAME

Additionally, try to do a restart of Sickrage and see if your update message comes back.


#6

Branch: master
Commit: 8564c29aa3b2d95bf41e03eed7e5a6938f1a6b3a
Version: 2016.09.03-1
Database Version: 44.0

mine says that I do not think its a database problem I looked at both sickrage the one done on the old setup as its not shut off yet and the only thing different I can is python versions, its not snatches the shows to download which is the problem its adding the shows to the hit list with plex too I have no idea


#7

Responded to your PM


#8

Ive had the same issue and what fixed it for me was to disable IPV6 on my server.

https://support.purevpn.com/how-to-disable-ipv6-linuxubuntu

The issue with the current Sickrage setup is that when you set web_host to a hostname that has both an IPv4 and IPv6 address, it binds to both and TheTVDB requests sends IPV6 requests instead of IPV4.

This happens automatically even if you have not enabled it in the sickrage settings.


#9

Agreed. IPv6 has been known to cause a ruckus with various applications that don’t necessarily make use (nor know how) the ipv6 protocol. This situation however was due to the Labor Day weekend apparently causing an overload on thetvdb.com api and thus connections were foo-bar. Seemed to have resolved itself after the busy weekend… I too was experiencing these same problems. It’d be great if they would implement the means for another indexer rather than always sticking to just one. These issues were far worse when they were using TVRage and they went down forever-ever.


#10

Thanks for the support on this problem


#11

My SR has decided not to add shows again, I have waited 4 days no change so looked at the link for disabling ipv6, when I use the 1st line of the command in putty I get error below, if i do disable ipv6 to get 1 programme to work will this have an effect on my system? since its been tuned its performed great.

enter this <gksudo gedit /etc/sysctl.conf > get this <-bash: gksudo: command not found>

system full root
Welcome to Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-38-generic x86_64)


#12

SickRage has been having more and more issues. It seems to be more a fault the the tvdb.com api more so than QuickBox or SickRage. You can see these issues as well within the SickRage github discussions.

However, disabling IPv6 will not harm your tuning. Just ensure that you only disable the IPv6 per the file and not try to adjust any other settings.


#13

thanks the command that is shown (gksudo gedit /etc/sysctl.conf) does not seem to work in my system i get <-bash: gksudo: command not found>


#14

You could just use nano /etc/sysctl.conf and disable ipv6 in the file.

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

then do sudo sysctl -p for the changes to take immediate effect.


#15

Thanks I will add all my new programs while its finding shows again, :slight_smile: