SickRage installer not working


#1

Hi,

When installing SickRage it does not work. I’ve tried via console or GUI, same issue.

Service Unavailable
The server is temporarily unable to service your
request due to maintenance downtime or capacity
problems. Please try again later.

Any suggestions?


#2

when you run

ps aux | grep sickrage

do you see it running? It should look something like:

/usr/bin/python /home/user/.sickrage/SickBeard.py -q --daemon --nolaunch --datadir=/home/user/.sickrage


#3

No sickrage is not running. Starting it manually with: systemctl start [email protected] does not work either.

2016-11-13 20:53:59 INFO     TORNADO :: Starting SickRage on http://localhost:8081/
2016-11-13 20:53:59 INFO     CHECKVERSION :: Checking for updates using GIT
2016-11-13 20:53:59 INFO     TORNADO :: Could not start webserver on port 8081, already in use!

EDIT2: port 8081 is not in use as I see it:

thebox:/home/user/.sickrage# sudo netstat -peant | grep ":8081 "
thebox:/home/user/.sickrage#

thebox:/home/user/.sickrage# ps aux|grep python
user     1106  0.3  0.2 281916 57028 ?        Ssl  20:53   0:19 /usr/bin/python /usr/bin/deluged -d
user     1119  0.0  0.2 107204 53440 ?        Ss   20:53   0:02 /usr/bin/python /usr/bin/deluge-web
root      1261  0.2  0.0 292220 18584 ?        Sl   20:53   0:13 /usr/bin/python3 /usr/bin/fail2ban-server -s /var/run/fail2ban/fail2ban.sock -p /var/run/fail2ban/fail2ban.pid -x -b
root      2488  0.0  0.0  14232   944 pts/2    S+   22:29   0:00 grep python
thebox:/home/user/.sickrage#

#4

This is extremely weird. Trying to alter Sickrage CONFIG.INI to use another port ie. 8082 results in the same problem! What on earth is going in here :open_mouth:


#5

This is a bit odd for sure. I’m assuming you’ve tried restarting the server to get rid of any orphan processes that might be interfering with the port usage?


#6

Yes, I’ve tried everything. This is a clean install, without any modifications. I’ve never seen this before.


#7

What happens if you just run:
Python /home/user/.sickrage/SickBeard.py

Does it kick out any errors ?


#8

Same issue :frowning:

12:15:31 INFO::TORNADO :: Starting SickRage on http://localhost:8081/
12:15:31 INFO::TORNADO :: Could not start webserver on port 8081, already in use!
12:15:31 INFO::CHECKVERSION :: Checking for updates using GIT

#9

What I’d you go total rogue and try to run it on port 90210?


#10

This port is outside the range of allowable ports; however choosing something random might not be a bad idea to rule out this nag


#11

you’re such a buzz kill @liara lol


#12

By default I disable IPv6 on all my systems. Enabling them again allowed Sickrage to start :fearful:

Why this caused a problem, is unclear to me, but now it works.

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

#13

Weird…

One thought here – if you try disabling ipv6 again and in the sickrage.conf change the bind to 127.0.0.1 from localhost does it work? How about with 0.0.0.0?