SFTP via CuteFTP key exchange failure


Trying to get SFTP connectrion.

ERROR:> [3/2/2018 3:12:34 PM] Algorithm negotiation failed.
ERROR:> [3/2/2018 3:12:34 PM] Can’t connect to SFTP21 error = #4. Disconnect: key exchange failed.

Can I force a common key algorithm or install one on my server or client side?

Standard Quick box on Ubuntu 16 with CuteFTP 8.3 ( I know it is older but hate the updated version)
I have FTPS explicit running, but wanted to connect sftp to run some comparisons. Is this a waste of time?


I used to love CuteFTP, but, I am going to have to say you’re wasting your time on this one. Here’s why:

  1. CuteFTP hasn’t been updated in over 5 years… it’s essentially abandoned. I hate how they are still willing to charge for an abandoned product. Shame on GlobalScape :frowning:
  2. CuteFTP doesn’t support newer, more secure, modern protocols. Namely SSLv2. I simply wouldn’t use it as it has it’s downfalls at this point and sometimes key authentication fails for this reason.

A for instance; check out their common errors article here. They don’t even list these issues on their error charts.

If you’re using it for multi-segmented downloading (which is why it used to be great), then I would either count that option out, or look to one of the solutions provided via the QuickBox install packages. I’d either swing for Syncthing or ResilioSync [BTSync]. These will perform downloads to your local sync client multi-segmented.


I loathe cute ftp but yea, multi segment is necessary or I only get 1/10th of the speeds out of my seedbox. But for Windows it is the only option. The tinfoil hat dev on filezilla has some ideological objection to multi segment ( quite astonishing actually to read his posts) and SmartFTP is anything but, it is not an option.

I was looking at Cygwin and Lftp.

But what you mention seems to be something other than FTP, like a live sync. that would be even better, as ATT is throttling my ftp or seedbox at the moment.

I don’t need ftp, just a way of getting files from my server fast as my connection allows.

I am now googling your suggestions.