Setquota cannot open quotafile


#1

Hello I recently decided to try out an OVH server with 2 hard drives to put in raid 0 and they have an annoying setup where you can’t put the / partition in raid 0 but instead it must be in raid 1. So I had to use the /home partition to do raid 0. I selected the /home option during the install and now when the install is finished when i go to setquota i get this result

setquota: Cannot open quotafile //aquota.user: No such file or directory

I believe you resolved a similar issue in the post below but I think it was done by you logging into the guys server and fixing it so I don’t know what you did. OS is Ubuntu 16.04 64 bit and thank you for the time you take to continue to improve this script


#2

This tells me that the mount is not being read by quota at all. Are you getting that error when you attempt to do the following:

quotaoff -a
service quota stop
mount -o remount /home
quotacheck -auMF vfsv1
quotaon -uv /home
service quota start

If so, what is the result of lsblk ?

If we can’t see anything out-of-sorts with that command, we’ll next need to take a peek at /etc/fstab. What is the output when you do cat /etc/fstab

Yes, yes they do! We’ll get it sorted out!


#3

When I run those commands I am able to set my quota but it doesn’t show up in my dashboard, under the “your disk status” area there is just the letters GB next to free,used, and size. also when I run the command "quotaon -uv /home I get this error:

quotaon: Mountpoint (or device) /home not found or has no quota enabled.

the result of lsblk is:

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 1.8T 0 disk
├─sda1 8:1 0 1004.5K 0 part
├─sda2 8:2 0 9.8G 0 part
│ └─md2 9:2 0 9.8G 0 raid1 /
├─sda3 8:3 0 1.8T 0 part
│ └─md3 9:3 0 3.6T 0 raid0 /home
└─sda4 8:4 0 511M 0 part [SWAP]
sdb 8:16 0 1.8T 0 disk
├─sdb1 8:17 0 1004.5K 0 part
├─sdb2 8:18 0 9.8G 0 part
│ └─md2 9:2 0 9.8G 0 raid1 /
├─sdb3 8:19 0 1.8T 0 part
│ └─md3 9:3 0 3.6T 0 raid0 /home
└─sdb4 8:20 0 511M 0 part [SWAP]

this is the /etc/fstab file

/dev/md2 / ext4 usrquota,errors=remount-ro,relatime 0 1
/dev/md3 /home ext4 defaults,relatime 1 2
/dev/sda4 swap swap defaults 0 0
/dev/sdb4 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
devtmpfs /dev devtmpfs rw 0 0


#4

Modify your fstab to look as follows:

/dev/md2 /       ext4   defaults,relatime 0 1
/dev/md3 /home   ext4   usrquota,errors=remount-ro,relatime 1 2
/dev/sda4 swap swap defaults 0 0
/dev/sdb4 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
devtmpfs /dev devtmpfs rw 0 0

#5

I edited the fstab and the result is the same. There is also an additional space in rutorrent down by the cpu usage and hard drive space left. I’ve attached pictures


#6

After you have edited fstab you will need to remount your quota.

quotaoff -a
service quota stop
mount -o remount /home
quotacheck -auMF vfsv1
quotaon -uv /home
service quota start

The double space is a result of your having a /(root) plugin and /home plugin enabled. Go to your plugins list and disable the plugin named diskspace. Leave diskspaceh enabled.


#7

alright everything works with the quota now in the dashboard area but when I disabled the diskspace plugin there is now just no hard drive indicator in rutorrent. Under the plugins tab I show diskspaceh being enabled and loaded but there is just no indicator in the bottom left corner. I only have the CPU usage down there now. a picture of how it looks is below. I also reloaded rutorrent to make sure that wasn’t the issue