Set up a CDN for Plex with CloudFlare & NGINX


#63

thats really insulting i would not ever use safari just like i never use internet expoder
lol i am running chrome but it also does same thing with the plex app


#64

Not that I am aware of.

He was asking a legitimate question, no need for that. Chrome has a whole host of issues in its own right.


#65

my bad XD lol was more playing around then being mean


#66

I have the same connection issue as @dtech (Chrome or FF) and also have issues playing back media from firestick,chrome and android client from time to time. I get a lost connection to plex media server … Retry or cancel and have to hit retry anywhere from 1 - 4 times before my media will play. I’m guessing this is somehow a timeout problem, just hoping someone can shed some light on this.


#67

I got it to work by going to the PlexPy settings > Plex Media Server

And change the server IP to the new IP you are using and changing the port to 80.


#68

I’m experiencing problems with this set-up, too. As much as I love the idea of using CloudFlare I think I’m gonna revert back changes.

I don’t think CloudFlare is causing any issues, I think the nginx reverse proxy config needs improving because it’s causing timeouts. CloudFlare on or off I see the same issues.


#69

So I had my failover IP go down this morning with soyoustart this got me thinking would it possible to add multiple ips, then have cloudflare have sub domains like plex,plex2 etc and have plex configured the same so basically it’s has failovers that are automatically picked up


#70

I have been experiencing some issues as well - I’m checking out a possible solution by removing the http2 configuration. The change just involves removing the http2 from the server 443 line.


#71

There was an issue with soyoustart earlier today they fixed it other than that this solution hasnt missed a beat. :slight_smile:


#72

i’ve noticed this when using a web browser on my mac. i pause for a few minutes and when i resume, it’ll kick me out and i have to hit play again… its kinda of nuisance, i agree. i get around this by using the Plex Media app. Hasn’t been an issue in that case.


#73

let me know if you figure this out :slight_smile:


#74

This issue is actually specific to Chrome. I haven’t noticed this issue if I use Firefox to access the web console.

Though my parents reported the PMP app to have this issue as well, strange that it works for you.

Overall, the ability to watch a remux here and there far outweighs any niggles I have with the ability to pause said remux and go make popcorn :sweat_smile:


#75

Got it fixed I’m dumb and didn’t put :443 at end


#76

i think something with this broke besides the custom server url. It did not seem like cloudflare was fixing peering still.


#77

many people have just started having issues 2 days ago, few reddit threads have popped up about plex not forwarding the custom urls to devices. taking the custom url out, saving settings, then readding the custom url is a temp fix. everything else works great, an easy test is pinging your ip vs cf forwarded url for me it is night and day. only issue is that vizio and sony tvs do not work (opera OS) even after the nonssl implementation.


#78

so its something plex broke!


#79

that is the consensus, as the custom domain still works if you go to it on the web but devices are not receiving the custom url, someone on reddit had mentioned they were monitoring their traffic and the plex app on tv/roku/whatever was requesting the ip thus not allowing it to load.


#80

Fix on the way


#81

great news, thank you


#82

Is anyone else having trouble with notifications with this setup? Plex no longer shows any scanning notifications and it doesn’t update in real time. A page refresh is necessary to get any sort of update for new movies, etc.