Server now shows Apache "its works" page instead of dashboard


#1

Hello,

after I installed and did some stuff the server seem to be working if i do server ip/rutorrent it loads and its running
but when I go to server ip which should show the dashboard, it now shows the famous apache its working page

this did not happen out of the box it happened after trying to install lets encrypt certificate, I probably messed up something along the way, is there a way to fix this without having to reinstall the OS and quickbox?

Thanks!


#2

you’ve probably missed the last step:

sed -i "s|DocumentRoot /var/www/html|DocumentRoot /srv/rutorrent/home/|g" /etc/apache2/sites-enabled/000-default-le-ssl.conf && service apache2 restart


#3

I love you! that was it :smile:


#4

I did exactly the same thing first time I built mine. :grinning:


#5

If you’re interested in making http://your.domain.net automatically forward to https://your.domain.net you can edit the following:

sudo nano /etc/apache2/sites-enabled/default-ssl.conf

scroll down until you find:

<VirtualHost *:80>

go to the bottom of that section, just above:
</VirtualHost>

insert the following lines, replacing your.domain.net with your letsencrypt domain

RewriteEngine on
RewriteCond %{SERVER_NAME} =your.domain.net
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,QSA,R=permanent]

the whole virtualhost sectoin should look something like this, remember to leave <VirtualHost *:443> alone :slight_smile:

<VirtualHost *:80>
        DocumentRoot "/srv/rutorrent/home"
        <Directory "/srv/rutorrent/home/">
                Options Indexes FollowSymLinks
                AllowOverride All AuthConfig
                Order allow,deny
                Allow from all
        AuthType Digest
        AuthName "rutorrent"
        AuthUserFile '/etc/htpasswd'
        Require valid-user
        </Directory>
SCGIMount /user 127.0.0.1:66372
RewriteEngine on
RewriteCond %{SERVER_NAME} =your.domain.net
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,QSA,R=permanent]
</VirtualHost>

#6

Thank you very much!


#7

I have a small question, in %{SERVER_NAME}

do I just leave it as it is, or does it mean server IP or something else?

Thanks!


#8

Leave that one the same. It’s only your.domain.net you need to change :slight_smile: