Seedbox updated to 17.04, Rutorrent Broken


#1

Anyone know how to fix this? I shoulda jsut stayed on 16, and didnt see 17.04 wasnt supported. Is my only answer redoing my seedbox?


#2

yes only way would be to reinstall the os


#3

Are you sure?

I just spoke to my friend who did the upgrade on his seedbox, same online.net seedbox server, and his upgraded to 17.04 with no issue. So there’s got to be a way to make it work


#4

well quickbox does not support it so not sure but could be if he upgraded then the dependencies were already their


#5

So i figured out that Rtorrent isnt broken at all. If i log in as the user, I can manually run “rtorrent” and it starts up and runs perfectly. But if i reboot the seedbox, i have to log back in as the user and do it again. In the past I never had to manually start the service.

Now I have 2 user accounts on there. Ron and 94tbird. 94tbird is the account that runs rtorrent, but any maintenance i do on the box, I use Ron. Is there any way to make the rtorrent service start automatically after a reboot as the user 94tbird without me manually logging in to do this?

also notice that if i log out of the console, rtorrent quits. it will only run when currently logged in


#6

There should be no need to manually start rtorrent as the service will fire up on boot automatically. It’s possible this is an openssl issue, however, I don’t have enough data to confirm this.

What happens if you run apt -y install rtorrent and then restart the service with systemctl restart [email protected]? 17.04 is not tested by myself at this time as I am opting to keep it on LTS for the time being and Ive not enough time in my day to test short life OS installs.


#7

Thanks for the response,

When I run the apt -y install rtorrent command, I am told that "rtorrent is already the newest version (0.9.6-2build1). "

When I run “systemctl restart [email protected]” I get no error message but Rtorrent is not running

If i log in as 94tbird and run rtorrent, it will start, but only for the current session, until i log out.


#8

Could you send a PM my way with login details to your server, I will try to figure out what’s going on with your install, however, I can’t guarantee anything as, once again, I’ve not tested anything with 17.04 and this could be an issue between your OS and rtorrent in general.


#9

Downgraded OS version