Safest way to upgrade Plex (Ubuntu 16.04)

ubuntu
16.04
plex

#1

Hello,

What is the safest or most reliable way to upgrade to the latest version of Plex? Currently on 1.84, but I see 1.90 out now as well. Using the command upgradePlex will install the latest version - but then my Plex blows up and is not accessible anymore. I’ve had this issue for the past few Plex builds. Therefore, I always have to have my libraries refresh from scratch.

I also find that only installing via “install box plex” (which only downloads 1.84 by the way), is the only safest way to have Plex up and running. Running the normal installation of Plex (sudo i dpkg method) does not allow me to access my Plex anymore.

Already running on 2.52 of QB.

Any thoughts or suggestions?

Thanks.


#2

upgradePlex = Upgrade Plex to newer version (if one exist) — works for plex pass and free accounts


#3

sounds like you have a bigger issue if the command blows up your install, i have no issue running the command to upgrade plex. dpkg -i should also not destroy your settings.

did you move your plex data dir to another location besides default and that is causing the issue?


#4

Additionally, I am assuming the (Ubuntu 14.04) is a type error?


#5

Hi Everyone,

Yes, 16.04.3 is the correct version (thanks).

So then there must be something off with my Plex installation then. Overnight, Plex auto-upgraded to 1.90 (plex pass), and I’m back to square 1 again in that the plex server is not available.

running sudo systemctl status plexmediaserver tells me it failed to start. Tried to stop/start the service, but eventually get to the same error.

checked my nano.conf file and it looks fine. Reran the permissions, and it looks fine.

I’ve only done either a “box install plex” installation, or using the QB button. Both will install just fine. But once an upgrade completes itself, I get the same error message.

Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

It’s using the default install folders (usr/lib/plexmediaserver/)

If I had to completely uninstall plex and restart from scratch…what method would you recommend?

Thanks.


#6

how do you get it working after the updates? do you tunnel every time and start a new library?


#7

Well in the past, I would literally have to uninstall and reinstall from scratch and then let Plex rebuild the library.

But just as an update, I did have a friend take a look at my install and it was apparently related to my locales. It’s all fixed now, so hopefully this issue won’t happen anymore. I’ll still keep an eye on it and update this thread for other’s benefit.

Thanks everyone.


#8

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.