Rutorrent won't start any torrent snatched from CouchPotato

couchpotato
rutorrent

#1

Hi all, installed everything today and it is amazing!

I just have one problem that is pretty much explained in the title. I’m trying to snatch torrents with CouchPotato and download them with ruTorrent, but the download never starts. Torrents are definitely found on CP, I get the pretty pop-up telling me the file has been snatched, it appears in ruTorrent and then nothing, it gets paused and can’t start by any mean… The torrent is working and downloads fine when I add it manually.

I activated BlackHole to download the torrent in a specific file:

And these are my settings for rTorrent:

host is http://163.172.59.91/thms/RPC2

I think the problem might come from the fact that I can’t find any torrent files in the directory I specified in the Blackhole settings, even after “succesfully” snatching them…

Any help would be very appreciated…


#2

Is there a reason why you are using blackhole and the rtorrent section?

I only use the rtorrent section

host url is: http://localhost/rutorrent/plugins/httprpc/action.php


#3

I tried with the same settings as yours, still the same problem :confused:

Also regarding Blackhole, it was on by default so I thought it was important!


#4

What does the CP log say? Does the connection test OK?


#5

Does the folder you are trying to download the torrents into already exist? (ie /home/thms/movies)

Usually torrents adding but not starting is a permissions issue


#6

turn blackhole off wipe out the pass and username use your scgi://localhost:Port# is in your .rtorrent.rc then everything should work :stuck_out_tongue:


#7

Alright so it looks like I can’t write in that folder for some reason which I don’t understand since that folder definitely exists… It is working with the default rtorrent directory though!

Is there a way to copy the downloaded files to another directory so I could read in there with Plex?