Rutorrent won't save value for automove and autowatch in autotools


So, I’m trying to configure autotools to point to my watched and download directories. The problem is, If I give it a folder outside my home directory, it just blanks it out and doesn’t accept it. I have my watch and download directories on another drive, so I really need to be outside my home directory. Is there a way to configure autotools that way?


If you’re saving outside of your users /home directory, you’ll need to make sure that the location/folders being saved to are r/w and owned by that user. If it still doesn’t work with the proper permissions, we’ll have to search for an answer as this I wouldn’t know much more about.

This is from wBuddha of Chmuranet:

With the autotools plugin, the owner of the destination folder needs to be the same as the user executing your web server. Generally that is user: www-data, group: www-data.

Try adding group permissions to your folder:

chgrp www-data NewFolder
Then add write permission for that group

chmod g+w NewFolder

So it looks like you’ll need those group permissions etc set to www-data, not necessarily the user.


Hmmm, that presents me with a conundrum, as the directory needs to be owned by my samba user so that I can share it.

I suppose I could make the samba user the www-data user, but that is kinda ugly.

Just adding the group permission wasn’t enough to make it work.


Have you added samba to the www-data group?


Yea, the userid that I’m running samba as is in the www-data group. Same result. It blanks out the field, and won’t let me save it. I’ve had this working in the past on this machine, but I don’t remember what I did to fix it.


Yea, another oddity related to permissions that I just discovered. I’m able to set my Downloads directory to /media/data1/, but if I attempt to set it to /media/data1/downloads/, it won’t accept it. It just reverts back to /media/data1/.

I know this is a permissions issue somehow, but I haven’t found the right permissions to set yet.


This is by setting the download directory through the .rtorrent.rc file?


directory.default.set = /home/USERNAME/torrents/rtorrent

To This

directory.default.set = /media/data1/downloads


Ahhh! Yep, that did it! now I just have to figure out how to get Autotools to be able to use those directories.


Yeah, I am actually digging through it right now trying to determine how it can be dealt with while USER-A needs access to WWW-DATA owned directories. As I’m discovering (just like you), it seems that even though the USER-A is being added to the group, it still wants those specific directories to be owned by WWW-DATA as the plugin itself is owned by WWW-DATA. Hopefully I’ll make progress on this over the weekend, maybe even tonight? I’m feeling crazy! :crazy_face:


lol, you’d be my hero if you figured it out! :slight_smile:

I’ve discovered that even with the permissions configured like this:

drwxrwxrwx 11 www-data www-data 4.0K Jan 24 21:37 watched

It still doesn’t work. I’m still digging also, and if I stumble across something, I’ll make sure to update the thread right away.


I still haven’t had any luck with this. I’ve tried all manner of permissions settings, and nothing seems to change when I change the permissions. I’m almost wondering if there is some other setting keeping autotools from being able to leave the home directory.


Ok, so I was able to make progress on this by doing the following. Instead of trying to figure out how to manipulate the permissions I needed, I just followed these instructions from Kram to mount the directory under my home:

This got me around the issue of not being able to navigate out of home, but now autowatch seems to be just deleting the .torrent file and not adding it to rtorrent.