Rutorrent tested but having problems


#1

Hi

i have been testing quickbox as a user i logged into ssh using the user and tried the reload command this is what i get

== Seedbox Shell ==
Welcome To Your QuickBox Seedbox Shell
Type ‘?’ to get the list of allowed commands
c#ch#eg#l:~$ reload
*** forbidden command: reload
c#ch#eg#l:~$

also i have transferred over some torrents and some .session files using ssh

scp -rp -P 4747 /home/user/rtorrent/.session/* [email protected]/home/user/.sessions/

scp -rp -P 4747 /home/userl/rtorrent/downloads/* [email protected]:/home/user/torrents/

chown -R user:user /home/user/.sessions/*

chown -R user:user /home/user/torrents/*

usually when this is done and i restart rutorrent they should show in the rutorrent interface but they are not ime wondering if the reload services button is working as i cant use reload logged in as user in ssh how can i check this and is there a way to reload a user from root

thanks


#2

It sounds to me as if you haven’t actually killed rtorrent and brought it back up fresh. If the reload function isn’t working you can either use the web panel (www-data should have permission to kill and pkill) or add “reload” to the list of allowed functions in /etc/lshell.conf.

Alternatively if you’re root you can just administer the command pkill -u (username) rtorrent


#3

thank you so much
that worked