ruTorrent missing


#1

ruTorrent option in sidebar is missing on fresh install of latest QuickBox on fully updated fresh install of Ubuntu 16.04. No issues during install process. rtorrent status is red. iRSSi-AutoDL is green.

I have tried disabling rtorrent, restarting, and re-enabling to no avail.


#2

try apt install rtorrent then reboot server


#3

Had you issued a reboot after the installation? As that is a needed part of the install.


#4

Rebooted, yes.


#5

Tried that, nothing.


#6

I just installed quickbox yesterday as well, and my ruTorrent is also missing from the dashboard.
Deluge is visible and accessible as well. I followed the suggested steps here as well, apt install rtorrent, reboot and no luck at all. Provided a screenshot of dashboard as well.

Going to https://server-adress/rutorrent/ I do get the following message:

[17.01.2018 18:30:53] WebUI started.
[17.01.2018 18:30:53] No connection to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file.

https://imgbox.com/698fplkA

Also while connected to my server I see this information:

sudo systemctl status [email protected]
[email protected] - rTorrent
Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2018-01-17 18:20:47 CET; 12min ago
Process: 6852 ExecStop=/usr/bin/killall -w -s 2 /usr/bin/rtorrent (code=exited, status=1/FAILURE)
Process: 6835 ExecStart=/usr/bin/screen -d -m -fa -S rtorrent /usr/bin/rtorrent (code=exited, status=0/
Process: 6833 ExecStartPre=/bin/rm -f /home/%I/.sessions/rtorrent.lock (code=exited, status=0/SUCCESS)
Main PID: 6837 (code=exited, status=0/SUCCESS)

Jan 17 18:20:47 queans systemd[1]: Starting rTorrent…
Jan 17 18:20:47 queans systemd[1]: Started rTorrent.
Jan 17 18:20:47 queans systemd[1]: [email protected]: Control process exited, code=exited status=1
Jan 17 18:20:47 queans systemd[1]: [email protected]: Unit entered failed state.
Jan 17 18:20:47 queans systemd[1]: [email protected]: Failed with result ‘exit-code’.

I have no clear idea on how to go about to error check nor solve this issue and wonder if it’s possible to get some help here.


I have no idea where or what the issue was, but copied the content in .rtorrent.rc from my other quickbox seedbox and restarted the server and it seems to work. And yes there was a rather huge difference in the rtorrent.rc file as well. And yes the difference was present before I did sudo apt install rtorrent. Might be the culprit?


#7

I am pretty sure this is an issue with the openssl libraries. Do apt -y install rtorrent and you should be good to go. I am currently looking into this and will have updates when available.


#8

Here is the content of the old/stock .rtorrent.rc

– START HERE –

dht = no
directory.default.set = /home/feasty/torrents/rtorrent
encoding.add = UTF-8
encryption = allow_incoming,try_outgoing,enable_retry,require_RC4
execute.nothrow = chmod,777,/home/feasty/.config/rpc.socket
execute.nothrow = chmod,777,/home/feasty/.sessions
network.port_random.set = yes
network.port_range.set = 8865-10365
network.scgi.open_port = localhost:8865
network.tos.set = throughput
peer_exchange = no
pieces.hash.on_completion.set = no
schedule = watch_directory,5,5,load.start=/home/feasty/rwatch/*.torrent
session.path.set = /home/feasty/.sessions/
throttle.global_down.max_rate.set = 0
throttle.global_up.max_rate.set = 0
throttle.max_peers.normal.set = 100
throttle.max_peers.seed.set = -1
throttle.max_uploads.global.set = 100
throttle.min_peers.normal.set = 1
throttle.min_peers.seed.set = -1
trackers.use_udp.set = yes
use_udp_trackers = yes

– END HERE –