Rutorrent can't connect to rtorrent

rtorrent
rtorrent.rc
rutorrent

#1

I’ve checked and double checked, reverted, googled, I can’t figure this out.

~/.rtorrent.rc has:

network.scgi.open_port = localhost:9693

and rutorrent’s config (/srv/rutorrent/conf/config.php) has:

$scgi_port = 9693;
$scgi_host = "127.0.0.1";

HOWEVER, the config file by default had the port set to 5000, and was working before. all I did was change the port range from what it was before to 8889-8889.
I’ve restarted a million times rtorrent and the whole server, rutorrent refuses to connect. All I get is:

No connection to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file.

This is my entire config:

#START HERE --
directory.default.set = /media/nas-share/Downloads
encoding.add = UTF-8
encryption = allow_incoming,try_outgoing,enable_retry
execute.nothrow = chmod,777,/home/seedbox/.config/rpc.socket
execute.nothrow = chmod,777,/home/seedbox/.sessions
network.port_random.set = yes
network.port_range.set = 8889-8889
network.scgi.open_port = localhost:9693
network.tos.set = throughput
pieces.hash.on_completion.set = no
protocol.pex.set = no
schedule = watch_directory,5,5,load.start=/home/seedbox/rwatch/*.torrent
system.file_allocate.set = yes
session.path.set = /home/seedbox/.sessions/
throttle.global_down.max_rate.set = 0
throttle.global_up.max_rate.set = 0
throttle.max_peers.normal.set = 1000
throttle.max_peers.seed.set = -1
throttle.max_uploads.global.set = 1000
throttle.min_peers.normal.set = 1
throttle.min_peers.seed.set = -1
trackers.use_udp.set = yes
# -- END HERE --

I did add some logging flags before reverting the entire config back, and rtorrent seemed to be accepting connections just fine, but rutorrent wasn’t showing anything.


#2

Change that localhost entry to a port within the specified range. Make sure it matches the users config as well as the SCGIMount port in the default-ssl.conf file in your apache directory.


#3

Within the specific range of what? the port_range.set ?

I set range to 8800-8900, changed the scgi port to 8850, changed the SCGIMount port (of which there are 3 entries in that file) to 8850, no go. I then tried changing the rutorrent conf port from 5000 to 8850, still no go.

Worth noting that the config in my OP works just fine on a second box I have that runs both plex and rtorrent, without any issues. I’m trying to recreate it due to other issues. Both are in VM’s on the same server.


#4

Is there a way to just completely remove rtorrent and reinstall? I tried the “downgrade” thing from the other thread, rebuilding and whatnot, that didn’t resolve this.


#5

I don’t think you’re editing the right file. I wouldn’t advise changing the port in that default rutorrent conf.

Are you editing this one?

/srv/rutorrent/conf/users/<USERNAME>/config.php

or this one?

/srv/rutorrent/conf/config.php

Additionally, after editing the default-ssl.conf. Did you issue a restart to apache?

Rebuilding will not help, this is a port issue in one of your configs.


#6

Oh wow. I wasn’t aware there was a different config, I should have guess though given this is designed more for multiple users. Changed it there and now it all works just fine.

Thanks for pointing me in the right direction :slight_smile:


#7

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.