rTorrent wont start


#1

Hello, i just installed quickbox yesterday and today i started having issues.
On the web console rtorrent wont start i did try restarting the service and rebooting the server but nothing.

Here are some of the errors i got

this is from systemctl status [email protected]

[email protected] - rTorrent
Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2016-10-01 17:39:55 CEST; 3min 56s ago
Process: 16386 ExecStop=/usr/bin/killall -w -s 2 /usr/bin/rtorrent (code=exited, status=1/FAILURE)
Process: 16373 ExecStart=/usr/bin/screen -d -m -fa -S rtorrent /usr/bin/rtorrent (code=exited, status=0/SUCCESS)
Process: 16372 ExecStartPre=/bin/rm -f /home/%I/.sessions/rtorrent.lock (code=exited, status=0/SUCCESS)
Main PID: 16377 (code=exited, status=0/SUCCESS)

Oct 01 17:39:55 sd-101710 systemd[1]: Starting rTorrent…
Oct 01 17:39:55 sd-101710 systemd[1]: Started rTorrent.
Oct 01 17:39:55 sd-101710 killall[16386]: /usr/bin/rtorrent: No such file or directory
Oct 01 17:39:55 sd-101710 systemd[1]: [email protected]: Control process exited, code=exited status=1
Oct 01 17:39:55 sd-101710 systemd[1]: [email protected]: Unit entered failed state.
Oct 01 17:39:55 sd-101710 systemd[1]: [email protected]: Failed with result ‘exit-code’.

And this is from the logs that i had rtorrent output to

1475331848 C Caught internal_error: ‘DownloadWrapper::receive_hash_done(…) Was not expecting non-NULL hash.’.
—DUMP—
/usr/lib/x86_64-linux-gnu/libtorrent.so.19(_ZN7torrent14internal_error10initializeERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0x227) [0x7fcd5bf106c7]
/usr/lib/x86_64-linux-gnu/libtorrent.so.19(_ZN7torrent14internal_errorC1EPKc+0xb8) [0x7fcd5bf0b868]
/usr/lib/x86_64-linux-gnu/libtorrent.so.19(+0xb1041) [0x7fcd5bf97041]
/usr/lib/x86_64-linux-gnu/libtorrent.so.19(+0xb1d30) [0x7fcd5bf97d30]
/usr/lib/x86_64-linux-gnu/libtorrent.so.19(+0x81a84) [0x7fcd5bf67a84]
/usr/lib/x86_64-linux-gnu/libtorrent.so.19(_ZN7torrent15signal_bitfield4workEv+0x5f) [0x7fcd5bf601bf]
/usr/lib/x86_64-linux-gnu/libtorrent.so.19(ZN7torrent11thread_base10event_loopEPS0+0x178) [0x7fcd5bf603c8]
/usr/bin/rtorrent() [0x412064]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7fcd5aa5d830]
/usr/bin/rtorrent() [0x415329]

—END—

Any help would be appreciated :smiley:


#2

Seems like there could be a possibility of a bad torrent.

Have you tried simply issuing the command rtorrent as your user? It rtorrent fails to start you will receive the error output same also if it starts but crashes shortly after. If it crashes after start, make note of the torrent hash and delete the corresponding torrent from .sessions


#3

I never tried it but it may work.

login as root and do these commands:

1- box remove rtorrent
2- box install rtorrent


#4

There is no install/uninstall script for rtorrent, so those commands will do nothing :slight_smile:


#5

Can’t blame I guy for trying. :wink:
I think such a command should exist.