Rtorrent wont start - new install


#1

Hi Guys,

i have tryed installing quickbox 3 times now with diffrent options during the install without any sucess.
i am unable to use rutorrent.
when i go to the web interface i get this error.
No connection to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file.

any help would be great.


#2

Hello,

Before everything, could you provide us more information about your system.
What’s your Linux distribution ? Which provider ? Etc.


#3

sorry about that
its running Ubuntu 16.04 LTS and its a brand new virtual server running on ESX that i built hosted in my data center
3gb mem, 4 cores 2tb space
during the install i picked rtorrent only and quota’s are turned on.


#4

Thanks,

Did you restart the server when the installation finished ?
The QuickBox dashboard from http://YourIpAdress/ is working ?
Does the rtorrent service is active ? sudo systemctl status [email protected]


#5

yes i restarted the server.
dashboard works fine.
rtorrent is showing as red on the dashbard
if i login as the user and try and start rtorrent it says
rtorrent: Error in option file: ~/.rtorrent.rc:10: Could not bind address: Name or service not known.


#6


had to take a screenshot because this forum wouldnt let me post the text


#7

Maybe rtorrent is already started and using the port.

Could you do ps -ef | grep rtorrent and kill any rtorrent returned?

After that, simply try : sudo systemctl start [email protected]


#8

nah rtorrent is not running.
i even did another reboot.
same error when i try to run rtorrent

rtorrent: Error in option file: ~/.rtorrent.rc:10: Could not bind address: Name or service not known.


#9

try a apt install rtorrent
might be that rtorrent just did not install for some stupid reason.


#10

managed to fix, just incase anyone else has this problem this is how i fixed it.

  1. apt install rtorrent
  2. edit /home/username/.rtorrent.rc and change line 10 from
    network.scgi.open_port = localhost:54058
    to
    network.scgi.open_port = 127.0.0.1:54058
  3. edit /srv/rutorrent/conf/users/username/config.php
    and change line 19 from
    $scgi_host = “localhost”;
    to
    $scgi_host = “127.0.0.1”;

#11

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.