[email protected] failing on fresh install


#1

Hello QuickBox team!

It’s been a while!

I’m trying to build a new ubuntu box (16.04) nothing special, just a space upgrade with Hetzner. I’ve ran the installation script, but ruTorrent fails to install (doesn’t show up on left side of dashboard). Unsurprisingly, other applications (sonarr, radarr etc) fail to load behind the reverse proxy.

Are there any known issues at the minute with the latest installation script?

The only troubleshooting I’ve been able to try are:
manually update && upgrade
then dist-upgrade
this is the third fresh install of 16.04 from the Hetzner image, I’m really at a loss as to what’s going on.

I’ll attempt a virtual machine tonight to see if it’s something screwy with Hetzner’s latest ubuntu images, but any input as always is appreciated.

Gar.

Edit:

If the error is helpful:

[[email protected]]:(0b)~$ sudo service [email protected] status
● [email protected] - rTorrent
   Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2018-06-03 01:57:26 CEST; 11min ago
  Process: 1002 ExecStop=/usr/bin/killall -w -s 2 /usr/bin/rtorrent (code=exited, status=1/FAILURE)
  Process: 979 ExecStart=/usr/bin/screen -d -m -fa -S rtorrent /usr/bin/rtorrent (code=exited, status=0/SUCCESS)
  Process: 951 ExecStartPre=/bin/rm -f /home/%I/.sessions/rtorrent.lock (code=exited, status=0/SUCCESS)
 Main PID: 982 (code=exited, status=0/SUCCESS)

Jun 03 01:57:23 fusiontv.org.uk systemd[1]: Starting rTorrent...
Jun 03 01:57:24 fusiontv.org.uk systemd[1]: Started rTorrent.
Jun 03 01:57:26 fusiontv.org.uk systemd[1]: [email protected]: Control process exited, code=exited status=1
Jun 03 01:57:26 fusiontv.org.uk systemd[1]: [email protected]: Unit entered failed state.
Jun 03 01:57:26 fusiontv.org.uk systemd[1]: [email protected]: Failed with result 'exit-code'.

Edit 2: confirmed virtual machine (16.04 server) worked with no issues, is there something strange with the Hetzner boxes? I saw a post on reddit talking about something similar, but the OP deleted their post so the fix wasn’t listed :frowning:


No connection to rTorrent issue
#2

try this
echo 'Acquire::ForceIPv4 "true";' | sudo tee /etc/apt/apt.conf.d/99force-ipv4
then apt install rtorrent


#3

Hey dtech! great to see you again!

So,

tried the IPv4 command, then tried installing torrent - rutorrent did appear, but rTorrent was still not responding.

SO, I rebuilt again, ran the echo command THEN I ran the quick box installation script - things are looking much more familiar now.

Still in the early stages of building, but it’s looking positive.

Any idea why the Hetzner image is behaving this way?


#4

They have problems when it comes to their ipv6 dns and not sure why but the commad I gave you is a quick fix to fix it you have to edit the interface settings and remove the ipv6 and just have v4 there. Also setting the DNS as Google does not hurt too much.


#5

It just does not download the dependencys that are required for everything which makes things like rtorrent fail.


#6

That explains why it ran with no problems on every other box I’ve tried. I’m assuming the IPV6 DNS is a new addition since I built my last hetzner.

Speaking of, I noticed a lot of their boxes are coming in a little cheaper than normal, if you have one it might be worth checking if you can save a few euro grabbing one with the same spec you have.

Do you know if there’s a ln idiots guide to disabling ipv6 on 16.04 - or is the command you already gave me all we need until hetzner sort their problems out?


#7

As for a guide I’d have to write out one but. If you would like I can do it for you pretty quickly just pm me your login and I’ll take care of it for you :slight_smile:

Also it’s a old problem of there’s so I don’t think they gonna fix it. But it’s only on some of the servers they have idk why I’m not the German wisper :laughing:


#8

Yeah noticed the prcing dropped a few bugs - just moved my server to a cheaper but same spec version but haven´t encountered an ip v6 problem so far.


#9

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.