Rtorrent keep crashing




it’s been some time since rtorrent keeps crashing but I can not figure out where the problem is. I’ll explain what happened:

a few weeks ago I uploaded some torrents (some of 10-15GB and even 2 of 45GB). But after a while I noticed that rtorrent was down. From that moment it was a constant problem. Every time I restarted, after a while, rtorrent crashed again. After many attempts I managed to stabilize the system by removing (via putty) all the files I had uploaded.
From that time the problem seemed to be solved: autodl-irrsi has downloaded many files of different sizes without problems.
But today I manually uploaded another big file (31GB) and the problem has reoccurred. Now after many many attempts (and after deleted the file just uploaded) the system seems to stable again.

It’s really a strange problem because it’s been a few months since I’ve changed anything in settings. Also I have always loaded large files, even 200GB, without a problem. I have 465GB of free space (I set a 100GB limit in rtorrent.rc).

What could be the problem? I could activate the rtorrent log but then I would not understand where the problem is. Do you have any suggestions on how to understand where the problem comes from? it is very strange because the problem appeared suddenly without doing anything.


rTorrent crashing when disk full

Hmm, could be a couple of things. What is the php version you’re running on your machine? php -v. With that we can examine the php.ini file and see if there are any buffers that should be increased.


Output of php -v is:

PHP 7.0.22-0ubuntu0.16.04.1 (cli) ( NTS )

Ubuntu is 16.04.3 LTS. In my rtorrent there are 2780 files (about 7.5Terabyte).


Could you PM me? We can go over your php.ini files to see if you need a buffer increase.



unfortunately, cause of my work, I find myself in a place where I have very poor internet connection. I’ll contact you as soon as I get home (probably next week).


Hi JMSolo,

I wrote a PM to you a week ago, but didn’t receive a reply. Anyway in the PM I wrote this:

I noticed that when I strart rutorrent, in the log window, compare only the words “webUI started” while “FILE MANAGER Ignited” is missing. Don’t know if this can be useful clue. However, if I do not add any torrents (neither manually nor through autodl-irssi), everything works normally.

After some days of testing I need to say that rtorrent keep crashing. Today after restarting rtorrent I found a new message in the log window: “FILE MANAGER: Failed to get directory contents : /” . And infact file manager doesn’t work. Also in the log of autodl-irssi I find this warning:" ERROR: Could Not Save AutodlState.xml ex: could not write to file xxxxxxxxxxxx". But I think that is caused by FileManager Plugin.

Any idea??

EDIT: I reinstalled the file manager plugin and now works. Ran the updater and restarted autodl-irssi, and also this is now working. But in the log window “FILE MANAGER Ignited” is always missing.


I’ll have to review this from an older version I have archived. I’ll run the update and see what’s amiss (possibly)



anyway…today it was impossible also to access rutorrent…as soon as I restarted rtorrent (from dashboard), it immediately crashed. During the night, autodl-irssi downloaded 2 small files (about 1.5GB)…after many many many attempt, I managed to access rutorrent and stop all files. I deleted the 2 downloaded files, restarted all the other files and now it works. I really can not understand what can cause this strange behavior.

P.s.: obviously I trust you, so, if you need, I can give you my root credentials


Hmm, corrupted torrents can cause anomalous behavior like that. One of those oddities that I’ve struggled with for years in dealing with rtorrent. Shouldn’t happen often, but it can and does happen. I wish I could technically understand why it happens also, I just may throw some research at it here soon.


continuing to investigate the problem I found a strange thing…

On my dashboard seems that I have 560GB of free space on my hard disk. But if I click “info” for my last added torrents, it says I have only 95GB of free space. And this after having deleted 90GB of files. Perhaps the problem was caused by the fact that the disk was full?? infact the problem only happens when new torrents are addedand; when I cancel these torrents, all works perfectly. Anyway…why on my dashboard it seems that instead there is still a lot of free space??

probably I did some error assigning quotas:

df -h --total
Filesystem     Type      Size  Used Avail Use% Mounted on
udev           devtmpfs   16G     0   16G   0% /dev
tmpfs          tmpfs     3.2G   53M  3.1G   2% /run
/dev/sda3      ext4      152G  7.0G  137G   5% /
tmpfs          tmpfs      16G     0   16G   0% /dev/shm
tmpfs          tmpfs     5.0M     0  5.0M   0% /run/lock
tmpfs          tmpfs      16G     0   16G   0% /sys/fs/cgroup
/dev/sda2      ext3      488M  197M  267M  43% /boot
/dev/sda4      ext4      8.0T  7.5T   96G  99% /home
tmpfs          tmpfs     3.2G     0  3.2G   0% /run/user/0
total          -         8.2T  7.5T  285G  97% -

As you can see my home is full