Rtorrent is down / chrashing

rtorrent
rutorrent

#1

I have just installed quickbox.io
I cant get rtorrent to run, deluge is running fine
I tried to run:
systemctl restart [email protected]
and then
systemctl status [email protected]:


#2

Do you have Quotas installed on your system? If yes, ensure you have assigned enough space to the user. If you do not need quotas, you can uninstall the package directly from your Package Management Center on your Dashboard.


#3

1.I have not installed Quotas.
2. I am using Ubuntu 16.04


#4

What version of ruTorrent did you install on the setup of QuickBox. This is the only report of rTorrent not working out of the box so I will need more details. However, it’s a hard place to start.


#5

output of rtorrent -h:
Rakshasa’s BitTorrent client version 0.9.6.


#6

FIXED :slight_smile::
When I was starting rtorrent from root everything was fine, but then I tried to do it as my seedbox user rtorrent was not starting. Look at screenshot for fix.

Thanks for trying to help.


#7

By default the permissions on the .sessions directory is 777. Additionally, you shouldn’t have to add service before a systemctl command.

I would not suggest anyone look to this as a fix for issues they may have starting rtorrent as you are showing that removing the rtorrent directory and adding it back is a plausible solution and that is a very problematic/destructive for people with data in that directory.

Just make sure the permissions are set and the directory is owned by your user.