Request for Radarr

feature-added

#22

How? I would like that too! Radarr is working perfectly with the script. Set up in seconds


#23

I updated the script with the new QuickBox locations :wink:

Don’t hesitate if you have any troubles!


#24

I’ve followed this: Setting up and using a custom menu in QuickBox

Here is my /srv/rutorrent/home/custom/custom.menu.php file:
// INSERT YOUR CUSTOM EXTERNAL or INTERNAL LINKS HERE! // $pydioURL= "https://" . $_SERVER['HTTP_HOST'] . "/pydio"; $quickboxURL = "https://plaza.quickbox.io/"; $radarrURL= "https://" . $_SERVER['HTTP_HOST'] . "/radarr"; $webtoolURL= "http://" . $_SERVER['HTTP_HOST'] . ":33400/"; ?> <!-- Do not remove this closing (?>) -->

<!-- // INSERT YOUR CUSTOM EXTERNAL or INTERNAL MENU ITEMS HERE! // -->
<li><a class="grayscale" href="<?php echo "$pydioURL"; ?>" target="_blank"><img src="img/brands/pydio.png" class="brand-ico"> <span>Pydio</span></a></li>
<li><a class="grayscale" href="<?php echo "$quickboxURL"; ?>" target="_blank"><img src="img/brands/quickbox.png" class="brand-ico"> <span>QuickBox Plaza</span></a></li>
<li><a class="grayscale" href="<?php echo "$radarrURL"; ?>" target="_blank"><img src="img/brands/radarr.png" class="brand-ico"> <span>Radarr</span></a></li>
<li><a class="grayscale" href="<?php echo "$webtoolURL"; ?>" target="_blank"><img src="img/brands/webtool.png" class="brand-ico"> <span>Plex WebTool</span></a></li>

You need to add the lines with radarr


#25

Looking for a little support, I have no doubt that the issues i am facing are entirely of my own making.

I have followed the above instructions and am having the same issue as @Shawn with “Radarr Ver.” on a with background. I have tried rebooting my server and running sudo systemctl restart radarr.
I cannot find the /.config/Radarr/config.xml file to check the urlbase, any pointers on that would be appreciated.
if anyone has any suggestions I wuld be only too happy to hear them.
Thanks


#26

try /home/MASTERUSER/.config/Radarr/config.xml

Masteruser being the user you have created for quickbox


#27

Thanks for the tip. but no luck in finding it… I have no idea what i have managed to do.
I figured i would start over and ran box remove radarr only to get this message
bash: /usr/local/bin/quickbox/package/remove/removepackage-radarr: No such file or directory. Ok but box install radarr shows that Package radarr already installed.
Now I have no clue how to remove what is there to start afresh.


#28

hello @dadof3monsters,

If you want to uninstall Radarr, you could do these things :

Log with root account : sudo su

  1. ls /opt/ => if you see Radarr’s folder, Radarr is installed (if not, go to point 7 directly)
  2. now you need to uninstall it with box remove radarr
  3. If you have the same message again bash: /usr/local/bin/quickbox/package/remove/removepackage-radarr it’s certainly because you deleted the install/remove package scripts.
  4. Reinstall them with the two one-line commands above in my first post
  5. Try to uninstall Radarr again with box remove radarr
  6. If it’s OK, the/opt/Radarr folder should not exist as well as the file.radarr.lock located in /install (ls -al /install)
  7. If everything before is OK, you could reinstall Radarr with sudo box install radarr
  8. When it finishes, the script will automaticaly start Radarr. If you see again the “Radarr Ver.”, you need to verify if the Radarr config file (config.xml) is created here /home/YourMasterUser/.config/Radarr (and btw if all others Radarr files are presents in the folder). If it exists, please look if the url base is set like this <UrlBase>radarr</UrlBase>. If not, replace it and restart Radarr with systemctl start radarr.service.

You can check Radarr’s status with systemctl status radarr.service (need to be “active (running)” to be OK.

Tell me when you are at this point and that Radarr is still not working :wink:

PS : you only need the root account for installing Radarr, rest of the time you should manipulate it with your master user and sudo command : sudo systemctl status radarr.service


#29

Thank you very much for the detailed response. I will be home later this evening when I will update with my progress and probably be asking for further assistance when I do something else stupid!!


#30

will this be available from the the dashboard in the near future? if so, i’ll just wait until then…

thanks!


#31

@dadof3monsters take your time, that needs some calm :stuck_out_tongue:

@pimogo I think about it, you can test for free with https://dply.co/ if you want, before installing it on your server :wink:


#32

I ran it and used some issues to help with a different software package it works great.


#33

Hmm, I’m also getting the loading bug with a blank radarr version. I found the config.xml and it has the correct URLbase and ‘sudo systemctl status radarr.service’ shows the process is running. Any ideas?

Thanks


#34

Installation script worked fine :slight_smile:

I have been trying to install some index throug Jackett. But every time i try to connect i get this message:

Message
Error: ConnectFailure (Connection refused): Error: ConnectFailure (Connection refused)

NzbDrone.Common.Http.HttpException: HTTP request failed: [401:Unauthorized] [GET] at [https://skankhunt42.quickbox.io/jackett/torznab/danishbits/api?t=movie&cat=2000,2010,2020,2030,2035,2040,2045,2050,2060&extended=1&apikey=1wnb5jxe7petijhtv132p4dxoq3y9wzk&offset=0&limit=100]
at NzbDrone.Common.Http.HttpClient.Execute (NzbDrone.Common.Http.HttpRequest request) [0x001a2] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\HttpClient.cs:103
at NzbDrone.Core.Indexers.HttpIndexerBase1[TSettings].FetchIndexerResponse (NzbDrone.Core.Indexers.IndexerRequest request) [0x00057] in C:\projects\radarr-usby1\src\NzbDrone.Core\Indexers\HttpIndexerBase.cs:311 at NzbDrone.Core.Indexers.HttpIndexerBase1[TSettings].FetchPage (NzbDrone.Core.Indexers.IndexerRequest request, NzbDrone.Core.Indexers.IParseIndexerResponse parser) [0x00000] in C:\projects\radarr-usby1\src\NzbDrone.Core\Indexers\HttpIndexerBase.cs:295
at NzbDrone.Core.Indexers.HttpIndexerBase`1[TSettings].TestConnection () [0x0000e] in C:\projects\radarr-usby1\src\NzbDrone.Core\Indexers\HttpIndexerBase.cs:325

401 Unauthorized

Unauthorized

This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.


Apache/2.4.18 (Ubuntu) Server at DNS.quickbox.io Port 443

I have also tryed to link Rtorrent and Radarr, but it wont work either…
I get this log message when i try.

System.Net.WebException: Error: ConnectFailure (Connection refused) —> System.Net.Sockets.SocketException: Connection refused
at System.Net.Sockets.Socket.Connect (System.Net.EndPoint remoteEP) [0x000d1] in <5641e4edad4f4464ba58c620a7b8ea48>:0
at System.Net.WebConnection.Connect (System.Net.HttpWebRequest request) [0x0019b] in <5641e4edad4f4464ba58c620a7b8ea48>:0
— End of inner exception stack trace —
at System.Net.HttpWebRequest.EndGetRequestStream (System.IAsyncResult asyncResult) [0x00043] in <5641e4edad4f4464ba58c620a7b8ea48>:0
at System.Net.HttpWebRequest.GetRequestStream () [0x00057] in <5641e4edad4f4464ba58c620a7b8ea48>:0
at CookComputing.XmlRpc.XmlRpcClientProtocol.Invoke (System.Object clientObj, System.Reflection.MethodInfo mi, System.Object[] parameters) [0x00077] in <9d687fb9c46d481292a78781773c6116>:0
at CookComputing.XmlRpc.XmlRpcClientProtocol.Invoke (System.Reflection.MethodInfo mi, System.Object[] Parameters) [0x00000] in <9d687fb9c46d481292a78781773c6116>:0
at XmlRpcProxyc51f4d68-6676-4f9a-9c61-e39c55f807ec.GetVersion () [0x00011] in <121f962618f045d3a6b2f814e6bb22a4>:0
at NzbDrone.Core.Download.Clients.RTorrent.RTorrentProxy.GetVersion (NzbDrone.Core.Download.Clients.RTorrent.RTorrentSettings settings) [0x00017] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\rTorrent\RTorrentProxy.cs:78
at NzbDrone.Core.Download.Clients.RTorrent.RTorrent.TestConnection () [0x00000] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\rTorrent\RTorrent.cs:193


#35

i try to install radarr in hetzner box but i getting this msg
sed: can’t read /home/hushman/.config/Radarr/config.xml: No such file or directory
sed: can’t read /home/hushman/.config/Radarr/config.xml: No such file or directory

i ready try chown -R hushman: /opt/Radarr/

same error any suggestion


#36

This might be your problem. When using Jackett, the indexer url in Sonarr and Radarr needs to look something like this: http://localhost:9117/torznab/danishbits.


#37

Thanks! That worked for me :slight_smile:

But i still also have trouple to get Rtorrent working with Radarr :confused:


#38

I get the exact same error on my hetzner box.


#39

Hey @PastaGringo,
could you update your script to the latest radarr version? You’ve linked to the 0.2.0.210 version, but the latest one is 0.2.0.654 :slight_smile:


#40

Just run the update from within the application, I just did and worked perfectly


#41

RADARR IS NOW INCLUDED as of the newly released #:v251