Remove reverse proxy


#1

Hi,

I’m using multiple VMs with multiple uses for each VM. One VM takes care of the reverse proxy for all the other VMs. However, because I’m now getting 192.168.1.238/plexpy - I can’t reverse proxy it to domain.tld/plexpy through the other VM.

I’m trying it like this:

location /plexpy/  {
        proxy_pass https://192.168.1.238/plexpy;
        proxy_set_header Host               $host;
        proxy_set_header X-Real-IP          $remote_addr;
        proxy_set_header X-Remote-Port      $remote_port;
        proxy_set_header X-Forwarded-Host   $server_name;
        proxy_set_header X-Forwarded-For    $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto  $scheme;
        proxy_set_header X-Forwarded-Ssl    on;
}

It does work if I use proxy_pass http://192.168.1.72:8181; (which is a non-reverse proxied plexpy on a different VM) so I would like to “disable” reverse proxy on the quickbox VMs.


#2

Couldn’t you simply remove the /etc/apache2/sites-enabled/plexpy.conf file and restart apache to achieve this?


#3

Tried that, getting ERR_CONNECTION_REFUSED when then trying to go do 192.168.1.238:8181


#4

Universal binds are disabled in all the rev proxy configurations to prevent bypassing apache auths.

Find http_host in config.ini and change it back to 0.0.0.0 from localhost.