Remove pass for download directory


#1

Hi, i wanna know how to remove the pass for the directory download ?
i try to set it like other topic on Downloads folder access to public
however, it still keep ask for user and password


#2

If you followed the information below properly, then there should be no issue for login. This part:

  AllowOverride None
  Order allow,deny
  allow from all

States that all traffic attempting to access this path will have publicly available access. Make certain that you have set this to read from a different location, such as /var/www/html/


It will require the creation of an alias in your apache configuration like the following:

Navigate to /etc/apache2/sites-enabled/ and open the aliases-seedbox.conf for editing.

At the bottom of the file, create a new alias for the directory you would like to be public like so…

Alias /public.download "/var/www/html/"
<Directory "/var/www/html/">
  Options Indexes FollowSymLinks MultiViews
  AllowOverride None
  Order allow,deny
  allow from all
</Directory>

You can name this alias whatever you like. Now save and close the file and reload apache with service apache2 reload

You can now navigate to the location via http://_your_server_ip_/public.download/ and your file will be listed and publicly available… all in the meanwhile, keeping your username out of the picture and held in a completely different directory than where rtorrent data resides.


Public Seedbox User
#3

sorry for my bad english, if i am not wrong, the “/var/www/html/” is the directory where we save our data ? is right ?


#4

No, this is simply a means to copy files to a publicly available directory. Your data is saved within /home/<username>/torrents/rtorrent

You can remove the password authentication requirements from your actual download directory by removing these lines from your /etc/apache2/sites-enabled/aliases-seedbox.conf file.

So you would change this:

Alias /<username>.rtorrent.downloads "/home/<username>/torrents/rtorrent/"
<Directory "/home/<username>/torrents/rtorrent/">
  Options Indexes FollowSymLinks MultiViews
  AuthType Digest
  AuthName "rutorrent"
  AuthUserFile '/etc/htpasswd'
  Require user <username>
  AllowOverride None
  Order allow,deny
  allow from all
</Directory>

To this:

Alias /<username>.rtorrent.downloads "/home/<username>/torrents/rtorrent/"
<Directory "/home/<username>/torrents/rtorrent/">
  Options Indexes FollowSymLinks MultiViews
  AllowOverride None
  Order allow,deny
  allow from all
</Directory>

However, please note that this is ill-advised and I would highly recommend not making your default https download directory a public facing element.

The best method is to copy files to the /var/www/html/ directory using the method I expressed before.


#5

now i got You don’t have permission to access /***.rtorrent.downloads/ on this server.

this is really confusing


#6

I have no idea how you are going about this. Did you add files to the var/www directory? Or are you trying to make /home/<username>/torrents/rtorrent/ public?


#7

i did both of it
first try to add files to var/www directory but it just show apache page
after that i try to make the home as public, the result is You don’t have permission to access /***.rtorrent.downloads/ on this server.


#8

This is to be expected. You need to actually add files there and remove the default index.html. By seeing that means it is working.

It is possible you are caching within your browser. Try to do a hard refresh by pressing Ctrl + f5 on your keyboard.


#9

try it several times the hard refresh, but still show forbidden
do i broke the script ?
try it on other browser and the result is same


#10

###This was solved via a custom solution in PM


#11