Remote Uploading

remoteupload

#1

I am having trouble getting a way to remote upload my torrents to other sites. Is there a way I can easily set this up?
I.E.
http://(MyIP)/username.downloads/clip.avi

As a direct link I can paste in to remote upload.

When I try to paste it in I get forbidden errors, even when doing the follwoing:
http://username:[email protected](MyIP)/username.downloads/clip.avi
I still get errors.


#2

I think the reason that will not work is it needs to log in. could you give few screenshots to help more explain what you’re trying to do and what your getting?
also what kind of remote uploads are you trying to do is it a site like torrents? or is it a file based site?
need more info before I can try and help. I think @JMSolo would also need little more info.

Thank you.


#3

You will need to setup the file as a ‘shared’ file.

Additionally, as @dtech has expressed. You are trying to share a file to a public file share repository, those databases will not be able to connect via browser based authentication.

Setting them up as a shared file however is the solution to this… good news is this… it’s built into ruTorrent.

When it is setup as a shared file, it will create a link such as this:

https://xxx.xxx.x.xxx/fileshare/share.php?uh=cXVpY2tib3g%3D&s=NbhPt2xlkMX5saq7z6wZ8148IQUJ0Bt2

Step 1 : Create your shared file

  • Navigate to ‘File Manager
  • In the file navigation, go to the ‘Torrents’ directory
  • Next, right click the file you would like to share and select ‘share’ from the popup.

Step 2 : Enter the amount of time the link is active to this shared file for download

  • A popup will now appear after selecting to ‘share
    • There is no need to enter a password here, leave it blank. Enter in a numeric value such as 24 and press the ‘Add’ button.

Step 3 : Grab the link created and share!

  • You will now see a tab called ‘File Share’, click on it.
  • Here you will see the file being shared, it’s amount of time left available as well as it’s public link.
  • Right click on the link and select ‘Copy link’. You can now paste the link wherever you like to have it shared openly for download.

#4

Thank you, I realize this is not really a problem with quick box and more of me trying to find a way to remote upload. Perhaps just moving the files in ftp to a non secured directory is the best way. For quickbox however what would I login too that would allow me to create that? My root account appears to be gone, so I can’t access /var/www
Anyway here are the errors I get when using share and remote upload. Knowing that they cannot do browser based authentication has answered that question though.
https://i.sli.mg/D3LNnp.png


#5

What do you mean by…

In your particular case, you will need to create a vhost record in apache to pickup the default directory. The easiest way to do this is to purchase a domain name. After you have a domain name you can set as many vhost as you like using whichever directories you so chose. By default, the apache configuration file used for picking up the root of the apache directories is located at /etc/apache2/sites-enabled/default-ssl.conf

Once you have a domain, add in the servername and alaias for both the subdomains and the main (seedbox) domain.

Your default default-ssl.conf will look like this:

SSLPassPhraseDialog  builtin
SSLSessionCache         shmcb:/var/cache/mod_ssl/scache(512000)
SSLSessionCacheTimeout  300
#SSLMutex default
SSLRandomSeed startup file:/dev/urandom  256
SSLRandomSeed connect builtin
SSLCryptoDevice builtin
<VirtualHost *:80>
        DocumentRoot "/srv/rutorrent/home"
        <Directory "/srv/rutorrent/home/">
                Options Indexes FollowSymLinks
                AllowOverride All AuthConfig
                Order allow,deny
                Allow from all
        AuthType Digest
        AuthName "rutorrent"
        AuthUserFile '/etc/htpasswd'
        Require valid-user
        </Directory>
SCGIMount /${username} 127.0.0.1:XXXXX
</VirtualHost>
<VirtualHost *:443>
Options +Indexes +MultiViews +FollowSymLinks
SSLEngine on
        DocumentRoot "/srv/rutorrent/home"
        <Directory "/srv/rutorrent/home/">
                Options +Indexes +FollowSymLinks +MultiViews
                AllowOverride All AuthConfig
                Order allow,deny
                Allow from all
        AuthType Digest
        AuthName "rutorrent"
        AuthUserFile '/etc/htpasswd'
        Require valid-user
        </Directory>
        SSLEngine on
        SSLProtocol all -SSLv2
        SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM:+LOW
        SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
        SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
        SetEnvIf User-Agent ".*MSIE.*"                  nokeepalive ssl-unclean-shutdown                  downgrade-1.0 force-response-1.0
SCGIMount /${username} 127.0.0.1:XXXXX
</Virtualhost>
SCGIMount /${username} 127.0.0.1:XXXXX

Under both <VirtualHost *:80> and <VirtualHost *:443> add the following:

ServerName domain.com
ServerAlias www.domain.com

So it will look like:

<VirtualHost *:80>
        ServerName domain.com
        ServerAlias www.domain.com
        DocumentRoot "/srv/rutorrent/home"
        <Directory "/srv/rutorrent/home/">
                Options Indexes FollowSymLinks
                AllowOverride All AuthConfig
                Order allow,deny
                Allow from all
        AuthType Digest
        AuthName "rutorrent"
        AuthUserFile '/etc/htpasswd'
        Require valid-user
        </Directory>
SCGIMount /_username_ 127.0.0.1:XXXXX
</VirtualHost>
<VirtualHost *:443>
        ServerName domain.com
        ServerAlias www.domain.com
        DocumentRoot "/srv/rutorrent/home"
        <Directory "/srv/rutorrent/home/">
                Options Indexes FollowSymLinks
                AllowOverride All AuthConfig
                Order allow,deny
                Allow from all
        AuthType Digest
        AuthName "rutorrent"
        AuthUserFile '/etc/htpasswd'
        Require valid-user
        </Directory>
SCGIMount /_username_ 127.0.0.1:XXXXX
</VirtualHost>
SCGIMount /${username} 127.0.0.1:XXXXX

Then, at the very bottom, add your new alias as follows:

<VirtualHost *:80>
    DocumentRoot "/var/www/html"
    ServerName subdomain.domain.com

    # Other directives here
</VirtualHost>

You should now be able to navigate to http://subdomain.domain.com and see the default apache page. You can move files here so they may be accessbile over the internet. Be aware however, that these files will be publicly accessbile.

Without knowing where you are attempting to remotely upload the files, thius is about the extent of the data I can give on this topic.


#6

I was trying to upload video files to VodLocker.

Thank you, I will try this, I do have a domain.


#7

Nice find! I didn’t know to make some files public.
First of all thank you @JMSolo for your amazing work with this script.
I learnt about it as I got my dedi tuned by swizards, and this is awesome so far.

Now, I tried to use fileshare, and I followed your steps on screenshots, but when I access the link I create, I get a 500 internal error.

Can you guide me to correct this?

Also, is there a way to update my build 2.1.1 to the latest one to correct .console and some other issues (like I can’t access via ssh if I create a new seedbox user and I cant use quota - package not installed - to assign space to a new user, and a few others)?

Thank you.


#8

Yes, if you are on 2.1.1 then there was a really minor oops in the .htaccess of the fileshare directory. Here is how you can fix that.

Navigate to /srv/rutorrent/home/fileshare

Now open in nano or your preferred editor, the .htaccess file.

Change this:

Satsify Any

to this:

Satisfy Any

Now save and exit the file. Like magic, your public shares should now be available.

As per:

I am working on a clean method of upgrading over the course of the next few days. I am trying to not distract myself with the new features… it’s hard to stay on point when I am excited to introduce new tools on the Dashboard. I will have an announcement posted as soon as that is available.

I would also like to go ahead and address some of your additional concerns here and now… just in the meantime. Also, sorry if my responses stop here in the next few… it’s my cakeday today and apparently I have plans. :open_mouth:

  1. When you say you can’t access ssh with new users, is it not allowing them to connect at all on port 4747?
  2. You say you cannot set quotas, is your system based on a /home partition or root (/), as these problems did exist in the v2.1.1 with home mounts.

I am certain that this 2.2.+ release will address many of these issues, although, if your server is tuned I would like to go through and fix these issues without mentioning the dreaded reinstall as they do phenomenal tunemanship. If anything, I could put together a history of tasks for you to put yourself current in the meantime.

Let me know and also, thanks for the kudos! Keeps me going!


#9

First of all Happy Cakeday!
Don’t mind me, enjoy your day my friend!

Now a funny one, I was staring at your Satisfy Any for a couple of minutes and couldn’t tell if you mistyped or I was a bit blind. I did not notice any difference.
Then I copied and pasted it into notepad :smile: Finally I noticed it.

Ok, I did that, I assume I need to restart rutorrent, as it doesnt work right now.

For your clean upgrade, no worries, take your time and release it whenever you can.
Liara told me you were working on it.

As for the minor issues, after I create with root a createSeedboxUser, it gets created fine, but I can’t ssh to the dedi if using its credentials. No biggie, I just wanted to give access to a friend to make some tests Sata vs SSD. But this can wait.
As for quotas, the system is /home partition. It says “quota” is not installed or something like this.
For .console, I solved it as I copied the folder .console from skel.

Thanks again!


#10

That’s what I thought. This isn’t as tasty as cake, but it will solve your quota woes.

Thanks for wishing me Happy Cake Day… I also need to tell the overly worked Liara “Hello” at some point.


#11

How would I go about allowing FTP user to access the var/www/html? Having trouble getting access to that folder.

EDIT by following this guide: http://askubuntu.com/questions/749697/how-do-i-give-myself-access-to-var-www-to-create-and-edit-files-and-folders-in I was able to do it. Thank you.

EDIT2 , Well I still can’t get the FTP directory I need to access to copy files to the subdomain show up on my user.

EDIT 3 Ok, I was simply able to just navigate to the webroot and then create a sym link to my torrents. Yay!

Edit 4 In short: Fastest way is simply, create the vhost, set the document root, ssh as sudo su, navigate to the document root, create symlink to torrents. So simple and gets the job done.


#12

Glad to hear you got this sorted and sorry for the late response (been pushing for the update).

I will take your effort here along with steps from the guide you posted and convert it to a Wiki for future users that may be in need of the same.

Thanks for posting your updates and solution!