quickVPN "waiting" issue


#1

I’ve discussed this on the chat with some of the admins, but I wanted to post it here just to see if anyone has found a solution. I went through the installation of quickVPN without any problems, downloaded the config file and placed it in my openvpn config folder etc etc. TUN\TAP is enabled,no firewall is enabled\setup. hosts file is correct. I’ve linked the exact openvpn log below from my desktop client. It stays on “WAIT” status and does not move.

Sat Apr 22 17:20:12 2017 OpenVPN 2.4.1 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Mar 22 2017
Sat Apr 22 17:20:12 2017 Windows version 6.1 (Windows 7) 64bit
Sat Apr 22 17:20:12 2017 library versions: OpenSSL 1.0.2k 26 Jan 2017, LZO 2.09
Sat Apr 22 17:20:12 2017 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25341
Sat Apr 22 17:20:12 2017 Need hold release from management interface, waiting…
Sat Apr 22 17:20:12 2017 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25341
Sat Apr 22 17:20:12 2017 MANAGEMENT: CMD 'state on’
Sat Apr 22 17:20:12 2017 MANAGEMENT: CMD 'log all on’
Sat Apr 22 17:20:12 2017 MANAGEMENT: CMD 'echo all on’
Sat Apr 22 17:20:12 2017 MANAGEMENT: CMD 'hold off’
Sat Apr 22 17:20:12 2017 MANAGEMENT: CMD 'hold release’
Sat Apr 22 17:20:13 2017 Outgoing Control Channel Authentication: Using 160 bit message hash ‘SHA1’ for HMAC authentication
Sat Apr 22 17:20:13 2017 Incoming Control Channel Authentication: Using 160 bit message hash ‘SHA1’ for HMAC authentication
Sat Apr 22 17:20:13 2017 TCP/UDP: Preserving recently used remote address: [AF_INET]xx.xxx.xxx.xxx:42450
Sat Apr 22 17:20:13 2017 Socket Buffers: R=[8192->8192] S=[8192->8192]
Sat Apr 22 17:20:13 2017 UDP link local: (not bound)
Sat Apr 22 17:20:13 2017 UDP link remote: [AF_INET]xx.xxx.xxx.xxx:42450
Sat Apr 22 17:20:13 2017 MANAGEMENT: >STATE:1492896013,WAIT,
Sat Apr 22 17:21:13 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Sat Apr 22 17:21:13 2017 TLS Error: TLS handshake failed
Sat Apr 22 17:21:13 2017 SIGUSR1[soft,tls-error] received, process restarting
Sat Apr 22 17:21:13 2017 MANAGEMENT: >STATE:1492896073,RECONNECTING,tls-error,
Sat Apr 22 17:21:13 2017 Restart pause, 5 second(s)
Sat Apr 22 17:21:18 2017 TCP/UDP: Preserving recently used remote address: [AF_INET]xx.xxx.xxx.xxx:42450
Sat Apr 22 17:21:18 2017 Socket Buffers: R=[8192->8192] S=[8192->8192]
Sat Apr 22 17:21:18 2017 UDP link local: (not bound)
Sat Apr 22 17:21:18 2017 UDP link remote: [AF_INET]xx.xxx.xxx.xxx:42450
Sat Apr 22 17:21:18 2017 MANAGEMENT: >STATE:1492896078,WAIT,
Sat Apr 22 17:22:19 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Sat Apr 22 17:22:19 2017 TLS Error: TLS handshake failed
Sat Apr 22 17:22:19 2017 SIGUSR1[soft,tls-error] received, process restarting
Sat Apr 22 17:22:19 2017 MANAGEMENT: >STATE:1492896139,RECONNECTING,tls-error,
Sat Apr 22 17:22:19 2017 Restart pause, 5 second(s)
Sat Apr 22 17:22:24 2017 TCP/UDP: Preserving recently used remote address: [AF_INET]xx.xxx.xxx.xxx:42450
Sat Apr 22 17:22:24 2017 Socket Buffers: R=[8192->8192] S=[8192->8192]
Sat Apr 22 17:22:24 2017 UDP link local: (not bound)
Sat Apr 22 17:22:24 2017 UDP link remote: [AF_INET]xx.xxx.xxx.xxx:42450
Sat Apr 22 17:22:24 2017 MANAGEMENT: >STATE:1492896144,WAIT,

thanks for any replies\suggestions!


#2

You mentioned it might be your provider. Did you check up on that?


#3

Yes. TUN\TAP is enabled on their end and they said they do not restrict VPNs on servers.


#4

It’s TLS - either your client isn’t configured correctly or your server hasn’t set up TLS correctly (it shoudl be automatic as part of the script.

I use a Chromebook & had to turn TLS off for compatibility reasons.

What client are you using & what operating system?
Have you tried using the .ovpn / .conf file on another device (OpenVPN for iPhone / Android e.g.)

It might help you narrow down client vs server problems.


#5

so I got past that message, then started to get a message that the connection was resetting. I looked that up and it either means the hosting company is blocking vpn connections (most likely) or the config file is faulty (its not I’ve done it 5+ times with different scripts\manually.)

ah, well… at least quickbox still works on this server!


#6

are you hosting the vpn on a dedicated server or is it a shared server? If you really want a VPN, I host mine with Scaleway, works a treat - Up until Cloudbit reset their servers the other day I’d recommend them, but they’re still working stuff out at the minute so for now I’d stay away :slight_smile: