Quickbox on Subdomain


#1

Hey there!

I’ve been trying to move my Quickbox Dashboard to a subdomain and have been having trouble. Here’s what I have so far:

000-default-le-ssl.conf

SSLPassPhraseDialog  builtin
SSLSessionCache         shmcb:/var/cache/mod_ssl/scache(512000)
SSLSessionCacheTimeout  300
#SSLMutex default
SSLRandomSeed startup file:/dev/urandom  256
SSLRandomSeed connect builtin
SSLCryptoDevice builtin

<VirtualHost *:80>
ServerName example.com
ServerAdmin [email protected]
DocumentRoot /var/www/html/
        <Directory "/var/www/html/">
                Options Indexes FollowSymLinks
                AllowOverride All AuthConfig
		Order allow,deny
		Allow from all
	Require all granted
        </Directory>
</VirtualHost>

<VirtualHost *:443>
Options +Indexes +MultiViews +FollowSymLinks
SSLEngine on
ServerName example.com
ServerAdmin [email protected]
DocumentRoot /var/www/html/
        <Directory "/var/www/html/">
                Options +Indexes +FollowSymLinks +MultiViews
                AllowOverride All AuthConfig
		Order allow,deny
		Allow from all
	Require all granted
        </Directory>
        SSLEngine on
        SSLProtocol all -SSLv2
        SSLCipherSuite ALL:!ADH:!EX41121:!SSLv2:RC4+RSA:+HIGH:+MEDIUM:+LOW
        SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
        SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
        SetEnvIf User-Agent ".*MSIE.*" \
                 nokeepalive ssl-unclean-shutdown \
                 downgrade-1.0 force-response-1.0
</Virtualhost>

<VirtualHost *:80>
		ServerName quickbox.example.com
		ServerAlias www.quickbox.example.com
        DocumentRoot "/srv/rutorrent/home"
        <Directory "/srv/rutorrent/home/">
                Options Indexes FollowSymLinks
                AllowOverride All AuthConfig
                Order allow,deny
                Allow from all
        AuthType Digest
        AuthName "rutorrent"
        AuthUserFile '/etc/htpasswd'
        Require valid-user
        </Directory>
SCGIMount /username 127.0.0.1:port
</VirtualHost>
<VirtualHost *:443>
Options +Indexes +MultiViews +FollowSymLinks
SSLEngine on
		ServerName quickbox.example.com
		ServerAlias www.quickbox.example.com
        DocumentRoot "/srv/rutorrent/home"
        <Directory "/srv/rutorrent/home/">
                Options +Indexes +FollowSymLinks +MultiViews
                AllowOverride All AuthConfig
                Order allow,deny
                Allow from all
        AuthType Digest
        AuthName "rutorrent"
        AuthUserFile '/etc/htpasswd'
        Require valid-user
        </Directory>
        SSLEngine on
        SSLProtocol all -SSLv2
        SSLCipherSuite ALL:!ADH:!EX41121:!SSLv2:RC4+RSA:+HIGH:+MEDIUM:+LOW
        SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
        SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
        SetEnvIf User-Agent ".*MSIE.*" \
                 nokeepalive ssl-unclean-shutdown \
                 downgrade-1.0 force-response-1.0
SCGIMount /username 127.0.0.1:port
</Virtualhost>

Unfortunately my subdomain is saying the DNS address couldn’t be found. I do have the DNS setup correctly with an A record pointing at the domain and a cname record for *.quickbox.domain.tld

Thanks!