Quickbox menu - link to plex not working


#1

Probably a simple fix for the experts on this board. I can live without it i suppose, but would be nice if the Quickbox menu item to Plex worked. When i click on it I get the following error: The requested URL /web/ was not found on this server.

Any quick fixes?

Thanks


#2

Would be nice with a bit more info about your operating system.

I’ll type the usual fix:

Run these 5 lines in terminal

sudo systemctl stop plexmediaserver.service
sudo mkdir -p /var/lib/plexmediaserver
sudo adduser --quiet --system --shell /bin/bash --home /var/lib/plexmediaserver --group plex
sudo chown -R plex:plex /var/lib/plexmediaserver
sudo systemctl start plexmediaserver.service

credit to @RXWatcher


#3

thanks for the response. i didn’t take the OS was critical to this as its the link from the Quickbox Dashboard Menu to Plex. Plex itself works fine. When I remote into my box I can access localhost:32400/web no problem. IN any case I’m running on Ubuntu 16.10.

I tried those steps, didn’t change the behavior.


#4

Can you manually type in http://SERVERIP:32400/web/ and this takes you to the Plex install on your server?


#5

it does. I can do it remotely even.


#6

i feel its a config entry in plex.conf under /etc/apache2/sites-enabled/.

The link from the dashboard menu does not include the port. which i like—its cleaner. but i require the port 32400 in order for the link to work.

not very good in linux… is there a line i can place in plex.conf to allow this?

thx!


#7

i actually think my issue is similar to gaz2030 (posted hours earlier) where you recommend making substantial changes to plex.conf… i tried replacing my plex.conf with yours (variables changed to my subdomain of course), but something happened (couldn’t access quickbox) and i had to revert back.


#8

Is there any hints of why this may had happened in your /var/log/apache2/error.log?


#9

Resolved via PM :smiley: