Quickbox Install Script - Sudoers group question


#1

Hi to all,

I have a very simple question for the Quickbox Install Script. During the Installation of Quickbox at one point i am being asked the following question:

Add a Master Account user to sudoers:

At this point i am entering a username that i have chosen. I must mention that the System that i am installing Quickbox on it is a fresh installed Ubuntu Linux 16.04 LTS distro and ONLY the root user exists. So the username that i am being asked above doesnt exist and so i chose the username mantax. So far so good. AFTER the Quickbox Install Script has succesfully finished and everything works fine i am trying to login via SSH as the root AND as the user mantax. I use for this procedure the Mac OS Terminal App and i can login to both accounts. I just want to figure out something about the user mantax. So i login again as root and type the following command:

groups mantax

And the output of the above in my terminal is:

mantax : mantax www-data

So the user mantax belongs to the groups mantax & www-data. BUT according to the question “Add a Master Account user to sudoers:” should the user mantax not also belong to the sudo group???

Update: Now i am a bit confused. I will explain why. I tried to login with the mantax user and edit a file that i DONT have read access to. For example i tried to edit the file “/etc/passwd-” with the command “nano /etc/passwd-” and i was not allowed to read it because i had no rights for it. BUT when i tried to enter “sudo nano /etc/passwd-” i was able to edit the file “/etc/passwd-” WITHOUT being asked for the passwd of the user mantax. So am i missing something?

a.) How can i have access to the sudo command with the user mantax in a moment where the user mantax doesnt belong to the sudoers group?

b.) And also i am used to that when i enter the sudo command i have to enter the passwd for the user that has sudo access. In the above example i was not being asked for a passwd after entering the sudo command.

Again i checked that the user mantax doesnt belong to the sudoers group by loging in as the root user and typing the command “groups mantax” and the output in my terminal was:

mantax : mantax www-data

Thanks in advance

George


#2

The user is in the /etc/sudoers file. go do a ‘visudo’ and look at that file.

Its not adding it to the sudoers group…only the file.

You arent prompted for a password based on the entry in /etc/sudoers:
user ALL=(ALL:ALL) NOPASSWD: ALL