Quickbox and whmcs


#1

Hi

i am using this amazing script and i am trying out whmcs to try and figure out automated setup
but i fell over at the first hurdle a feature it has is server status which monitors the server and gives you info realtime
i need to upload the status folder but it has to be to somewhere publicly accessible ive tried putting it in many places after quickbox install but it dont work, what i am asking is where is a publicly accessible folder on the server

i have tried uploading it to /var/www/ and /var/www/html

is there a publicly accessible folder

this might help https://www.youtube.com/watch?v=0w7YcalU078

thanks for any help


#2

You would be right by placing it in /var/www/html. The next step would be adding in an alias that ensures that is reachable publicly.

In your particular case, you will need to create a vhost record in apache to pickup the default directory. The easiest way to do this is to purchase a domain name (I assume you already have one). After you have a domain name you can set as many vhost as you like using whichever directories you so chose. By default, the apache configuration file used for picking up the root of the apache directories is located at /etc/apache2/sites-enabled/default-ssl.conf

Once you have a domain, add in the servername and alaias for both the subdomains and the main (seedbox) domain.

Your default default-ssl.conf will look like this:

SSLPassPhraseDialog  builtin
SSLSessionCache         shmcb:/var/cache/mod_ssl/scache(512000)
SSLSessionCacheTimeout  300
#SSLMutex default
SSLRandomSeed startup file:/dev/urandom  256
SSLRandomSeed connect builtin
SSLCryptoDevice builtin
<VirtualHost *:80>
        DocumentRoot "/srv/rutorrent/home"
        <Directory "/srv/rutorrent/home/">
                Options Indexes FollowSymLinks
                AllowOverride All AuthConfig
                Order allow,deny
                Allow from all
        AuthType Digest
        AuthName "rutorrent"
        AuthUserFile '/etc/htpasswd'
        Require valid-user
        </Directory>
SCGIMount /${username} 127.0.0.1:XXXXX
</VirtualHost>
<VirtualHost *:443>
Options +Indexes +MultiViews +FollowSymLinks
SSLEngine on
        DocumentRoot "/srv/rutorrent/home"
        <Directory "/srv/rutorrent/home/">
                Options +Indexes +FollowSymLinks +MultiViews
                AllowOverride All AuthConfig
                Order allow,deny
                Allow from all
        AuthType Digest
        AuthName "rutorrent"
        AuthUserFile '/etc/htpasswd'
        Require valid-user
        </Directory>
        SSLEngine on
        SSLProtocol all -SSLv2
        SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM:+LOW
        SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
        SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
        SetEnvIf User-Agent ".*MSIE.*"                  nokeepalive ssl-unclean-shutdown                  downgrade-1.0 force-response-1.0
SCGIMount /${username} 127.0.0.1:XXXXX
</Virtualhost>
SCGIMount /${username} 127.0.0.1:XXXXX

Under both <VirtualHost *:80> and <VirtualHost *:443> add the following:

ServerName domain.com
ServerAlias www.domain.com

So it will look like:

<VirtualHost *:80>
        ServerName domain.com
        ServerAlias www.domain.com
        DocumentRoot "/srv/rutorrent/home"
        <Directory "/srv/rutorrent/home/">
                Options Indexes FollowSymLinks
                AllowOverride All AuthConfig
                Order allow,deny
                Allow from all
        AuthType Digest
        AuthName "rutorrent"
        AuthUserFile '/etc/htpasswd'
        Require valid-user
        </Directory>
SCGIMount /_username_ 127.0.0.1:XXXXX
</VirtualHost>
<VirtualHost *:443>
        ServerName domain.com
        ServerAlias www.domain.com
        DocumentRoot "/srv/rutorrent/home"
        <Directory "/srv/rutorrent/home/">
                Options Indexes FollowSymLinks
                AllowOverride All AuthConfig
                Order allow,deny
                Allow from all
        AuthType Digest
        AuthName "rutorrent"
        AuthUserFile '/etc/htpasswd'
        Require valid-user
        </Directory>
SCGIMount /_username_ 127.0.0.1:XXXXX
</VirtualHost>
SCGIMount /_username_  127.0.0.1:XXXXX

Then, at the very bottom, add your new alias as follows:

<VirtualHost *:80>
    DocumentRoot "/var/www/html"
    ServerName subdomain.domain.com

    # Other directives here
</VirtualHost>

You should now be able to navigate to http://subdomain.domain.com and see the default apache page. You can then move any files here so they may be accessible publicly over the internet.


Run php apps beside Quickbox
#3

Thanks

i did exactly what was said but it is asking for authentication to access the page username and password


#4

Modify your new VHost to not ask for auth. Like this:

<VirtualHost *:80>
    DocumentRoot "/var/www/html"
    ServerName subdomain.domain.com
    <Directory "/var/www/html/">
          Options Indexes FollowSymLinks
          Order allow,deny
           Allow from all
     </Directory>
</VirtualHost>

See if that helps.

####Edit: I added the directory in there as it may be needed.


Setting up reverse proxy to get around existing server on LAN
#5

thanks i done that now on apache2 restart i get this

dedi-fr-56988:~# service apache2 restart Job for apache2.service failed because the control process exited with error code. See “systemctl status apache2.service” and “journalctl -xe” for details.


#6

Check my edit and see if that helps. If it still produces an error then post for me the output of systemctl status apache2.service -l


#7

yes i added the edit but still got the same error here is the log

● apache2.service - LSB: Apache2 web server
Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
Drop-In: /lib/systemd/system/apache2.service.d
└─apache2-systemd.conf
Active: failed (Result: exit-code) since Sat 2016-07-16 22:20:07 CEST; 4min 45s ago
Docs: man:systemd-sysv-generator(8)
Process: 61772 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
Process: 28705 ExecReload=/etc/init.d/apache2 reload (code=exited, status=0/SUCCESS)
Process: 61964 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

Jul 16 22:20:07 dedi-fr-56988 apache2[61964]: *
Jul 16 22:20:07 dedi-fr-56988 apache2[61964]: * The apache2 configtest failed.
Jul 16 22:20:07 dedi-fr-56988 apache2[61964]: Output of config test was:
Jul 16 22:20:07 dedi-fr-56988 apache2[61964]: apache2: Syntax error on line 219 of /etc/apache2/apache2.conf: Sy
Jul 16 22:20:07 dedi-fr-56988 apache2[61964]: Action ‘configtest’ failed.
Jul 16 22:20:07 dedi-fr-56988 apache2[61964]: The Apache error log may have more information.
Jul 16 22:20:07 dedi-fr-56988 systemd[1]: apache2.service: Control process exited, code=exited status=1
Jul 16 22:20:07 dedi-fr-56988 systemd[1]: Failed to start LSB: Apache2 web server.
Jul 16 22:20:07 dedi-fr-56988 systemd[1]: apache2.service: Unit entered failed state.
Jul 16 22:20:07 dedi-fr-56988 systemd[1]: apache2.service: Failed with result ‘exit-code’.


#8

What is on that line in that file? It should be:

IncludeOptional sites-enabled/*.conf

If it is, then it is saying that there is an error “somewhere” in your .conf file.


#9

Include module configuration:

IncludeOptional mods-enabled/.load
IncludeOptional mods-enabled/
.conf

oh edit its there

IncludeOptional sites-enabled/*.conf

thats all that is there in the conf


#10

Shoot me a PM and I can take a quick look for you before I head back out of the house.


#11

@coaster Hi, did you manage to fix QuickBox into WHMCS? If so are you available for either help or paid custom?


#12

Hi

no i didnt its a shame really but maybe when JMsolo isnt busy he might take a look


#13

I would also be very interested in this.


#14

This seems like it would be for commercial use. Perhaps you can pay someone for it?


#15

Gladly. That’s what I and other guy was inferring if somebody has the time/willing :slight_smile: