Quickbox 2.3.4 issue


#1

Fresh install of quickbox 2.3.4 on debian 8 with the disk set as root (/).

Autodl-irssi issues:

  1. Formatting of the irssi plugin(where you check versions, backup/restore configs) is wrapped when using the Oblivion theme and the text in the autodl section for updates, etc is larger than when using the swizard theme. Everything looks correct when using the swizards theme.
  2. I cant restore or backup an irssi config on either theme.
    Other issue:
  3. Does setdisk always have to be run post application load? I seem to have to always run it for my user I create when I load quickbox.

I have wiped this server completely and tried again…issues remain,

I have tried on firefox and chrome…both exhibit the issues above.

Thank you for your efforts on this.


#2

might try using ubuntu, but as for the setdisk command it only sets a quota for whatever user you put in when running it. if you run it and it does not show in the disk space correctly then you might have used the wrong install option when installing quickbox. I don’t know much about IRSSI so i can’t help with it.

but i am willing to bet @JMSolo will be able to help when he is on tomorrow he is hopefully getting some good sleep as of now.
He has done a lot of amazing work here.


#3

Hey there @RXWatcher

I think I found this issue as well. The autdl plugin naming was malformed. Do you by chance have two plugin tabs for autodl-irssi.

The naming was set as autodl_irssi (the bad one) and autodl-irssi (the good one). I have gone in and fixed the naming on this but I am thinking since the naming was bad on that, it is not recognizing it’s own directory tree for it to pull updates. More than likely you should be able to just rename it and it will function as it should.

This may additionally add to the not being able to backup/restore as it is attempting to read from a parent directory it does not recognize.

As per setdisk, that is unusual behavior that is not to happen on any of our supported Distro/Rel. When you say load QuickBox… do you mean by simply refreshing the page and/or navigating to it initially?


#4

that did it. In the plugins tab of quickbox I had the autodl_irssi. I pulled an update via quickbox and refreshed and I had the autodl-irssi plugin. I enabled this and refreshed rutorrent. This produced two plugin tabs in the middle but I was able to restore my config for autodl. I then went into /srv/rutorrent/plugins and removed the autodl_irssi plugin dir and reloaded rutorrent. All is good! Thank you!

The setdisk issue is using online.nets debian 8 install. I did a fresh OS load with the base OS as is, then installed quickbox per your main page:
apt-get -y update; apt-get -y upgrade; apt-get -y install git lsb-release;
git clone --recursive https://github.com/QuickBox/QuickBox QuickBox &&
bash ~/QuickBox/setup/quickbox-setup

I chose not to do the ffmpeg and to enable public trackers otherwise all defaults. I chose to create a user who did not exist before. I let it install and then rebooted. I went to the rutorrent for my user and I got the warning about being out to space. I then SSHed into the box, sudoed to become root, ran setdisk and specified my user and gave it all available space and then refreshed rutorrent and the issue disappeared.