QP Setup: Private IP used instead of Public IP

vps
scaleway

#1

So I got myself a cheap Scaleway VPS (VC1S) and did the QP setup. The setup ran smoothly bar one error with vsftpd.

Anyhoo, once it was setup. I noticed that the IP address it used for the dashboard was the private IP and not the public IP.

I can access the dashboard using the public IP. It hasn’t been that much of a nuisance as I’ve found ways to get around it but I’d still like to know what caused it and how I can prevent it happening again.


#2

It would probably require some type of ‘Whats my IP address’ search to overcome this NATing to put the public IP in there and quickbox isnt setup for that. You could code something and do a pull request but I think if you look at an 80/20 rule that this would fall into the 20%. Most users have a static IP address.


#3

I used that command ip=$(curl -s http://whatismyip.akamai.com) into my script to get the external IP. But I don’t know if this service will stay alive forever… :confused:


#4

Having the same issue; how did you work around this?


#5

I’m not sure what you mean but like I said in my original post, I was still able to access the dashboard using the public IP address after the setup. So I guess that’s how I got around it. Also, the installation scripts for the various apps will use the private IP, all I did to fix that was change the .conf files in /etc/apache2/sites-enabled so that it uses the public IP instead of the private IP.


#6

I use a scaleway for a VPN server. A small word of caution that the internal IP address changes when you stop/start your server.


#7

Got it working perfectly now, I had an issue with apache not configuring correctly.


#8

Any TIPS??? I can install but soon as I reboot the server it never comes back up??