QB 2.3.7 - Sonarr and Quassel not working


#1

Hi there

made an update 30 mins ago and after this:
Sonarr doesn’t seem to work
Quassel can´t be installed only shows a blank status after clicking Install.
http://i.imgur.com/fLyWfS3.jpg

Using Chrome - Running on Deb. 8.5.


#2

id try rebooting the server just so anything that needs to start up will i know there are many other ways but who knows reboot might help.
can’t hurt


#3

Hey there Dtech

You´re right…
tried that sadly still the same result!


#4

ok well i only know ubuntu so i dont know that i can be much help with Deb
the chrome browser is not the problem i can tell you that. have you tried removing the package then re adding it?


#5

I’ll admit there might be bugs in the quassel install I wrote today. I unfortunately only had time to write it, not test it :blush: I haven’t had any confirmed installs yet

I will look into this once I’ve had some sleep

The sonarr may be fixed in a fresh install?


#6

@dtech
yeah tried that sadly the same result!

@liara
Don´t forget to get that sleep…

Hope you mean a fresh install of Sonarr only and not Quickbox?
Tried that and sadly that didn´t work.

Give me a heads up if its ready for test - I´d be happy to help out :slight_smile:


#7

yeah if you wait tell tomorrow, both @liara & @JMSolo
can also help you they just need to get some good sleep so they can be on their game :smiley:
they do a lot of work and do need it.


#8

Yeah they do some awesome work :slight_smile:

Btw…the controls are acting wierd after uninstalling Sonarr.
3 of 5 Service controllers were stopped.
BTSync was disabled
http://i.imgur.com/FYApS3T.jpg


#9

The toggles are that way due to the startup file being reset on uninstall. Just toggle them back to the ‘On’ position. Doing so will not affect the running services… only put them back.


#10

When you do service sonarr status what is the output? Someone else had an issue with this on their local server, but the issue vanished on an external VM. I am not sure if this is some sort of anomaly with certain servers and their settings or the script.


#11

Yeah saw that topic too but would be a sad panda if I had to reinstall everything from scratch once more.

Here´s the output:
TheBox:~# service sonarr status
● sonarr.service - LSB: starts instance of NzbDrone
Loaded: loaded (/etc/init.d/sonarr)
Active: failed (Result: exit-code) since Wed 2016-06-22 14:40:01 CEST; 2s ago
Process: 21154 ExecStart=/etc/init.d/sonarr start (code=exited, status=2)

Jun 22 14:40:01 TheBox sonarr[21154]: Starting Sonarr-NzbDrone
Jun 22 14:40:01 TheBox sonarr[21154]: start-stop-daemon: unable to stat /op...y)
Jun 22 14:40:01 TheBox systemd[1]: sonarr.service: control process exited, ...=2
Jun 22 14:40:01 TheBox systemd[1]: Failed to start LSB: starts instance of ...e.
Jun 22 14:40:01 TheBox systemd[1]: Unit sonarr.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
TheBox:~#

#12

Hmm, alright. If it is installed could you try to run service sonarr start and see if that enables the service? Otherwise, if you don’t mind PM’ing me some credentials I can login to your server and work out a solution as to why this may be happening only on certain servers… I would definitely not want you to re-install anything as that would then start defeating the purpose of "Quick"Box :blush:


#13

I´d have absolutely no problem with that - feel free to pm me :slight_smile:

Here´s the output:
TheBox:~# service sonarr start
Job for sonarr.service failed. See ‘systemctl status sonarr.service’ and ‘journalctl -xn’ for details.
TheBox:~#


#14

The PM has been sent. We’ll get this sorted. :thumbsup:

###Update:

This has been resolved and I am going to push an update to the QuickBox package repo shortly. The issue is that the mono-project’s own repository is failing to install the mono package on Debian installations. Thanks @Globber for allowing me to check this on your server to find a proper fix.


#15

And thanks a lot to @JMSolo for finding and fixing the Sonarr issue :slight_smile:


#16

This issue remains for me on a fresh install last night with Debian 8.


#17

I think this may had been an issue where the function definitions were not preceding the functions themselves. Since Debian distributions are an [else] statement in the installer for sonarr I am certain that what was happening is that mono-devel packages were being skipped, thus nzbdrone would not install properly. I just tested this on a fresh install of Debian 8 and an already installed Debian 8 and it seems to fix the issue. You should be able to run the update now to have the fix pulled.

###Here is the commit just pushed:
https://github.com/QuickBox/quickbox_packages/pull/73/commits/ff4d3d87d78f06c8baa3ddff7e7c07084f823662


#18

still not working with an online.net box. There is nothing in /opt/
Job for sonarr.service failed. See ‘systemctl status sonarr.service’ and ‘journalctl -xn’ for details.

Is there a log file that I can look at to dig into see whats going on?

Thanks!


#19

More than likely your mono packages are not installing. Try this out.

echo "deb https://apt.sonarr.tv/ master main" | sudo tee -a /etc/apt/sources.list.d/sonarr.list
sudo apt-get -y update
sudo apt-get install -y mono-devel
sudo apt-get install -y nzbdrone
sudo rm /etc/apt/sources.list.d/sonarr.list

Not sure why this wouldn’t be functioning after the fix. I will look further into the function tomorrow. I have an online.net server I can run this against as well.


#20

Yes, the output of the two commands mentioned there :wink:

systemctl status -l sonarr

journalctl -xn

Likely there will be an error message in one of those that will help give us a clue to the issue