PyLoad not loading


#1

Hi @JMSolo,

This is regarding PyLoad package. I’m able to run the Web interface when i run the following command from

/home/user/.pyload/pyLoadCore.py and if i close the SSH session or enter Control C the Pyload stops working. I have searched google and it says I have to add it as service to load it in the background.


#2

That is what the systemd script does that fires it from your dashboard.

You should run setup-pyLoad after you install from either box or your dashboard. Then you can either type systemctl restart [email protected] or hit the refresh button for it on your dashboard.

Try that and then tell me what the return is from systemctl status [email protected]

Replace USERNAME with the actual username.


#3

Here is the output from systemctl status [email protected]

[email protected] - pyLoad
Loaded: loaded (/etc/systemd/system/[email protected]; enabled)
Active: failed (Result: resources) since Tue 2016-08-30 20:53:35 CEST; 34s ago
Process: 30994 ExecStart=/usr/bin/python /home/sabhxda/.pyload/pyLoadCore.py --config=/home/sabhxda/.pyload --pidfile=/var/run/pyload/pid --daemon (code=exited, status=0/SUCCESS)

Aug 30 20:53:35 lowseed python[30994]: Daemon PID 31028
Aug 30 20:53:35 lowseed systemd[1]: [email protected] never wrot…
Aug 30 20:53:35 lowseed systemd[1]: Failed to start pyLoad.
Aug 30 20:53:35 lowseed systemd[1]: Unit [email protected] enter…
Hint: Some lines were ellipsized, use -l to show in full.

Output of systemctl restart [email protected]

systemctl restart [email protected]
Job for [email protected] failed. See ‘systemctl status [email protected]’ and ‘journalctl -xn’ for details.


#4

Will you do the uninstall and install it once more. Do the setup-pyLoad after the install and then refresh to start the service from your dashboard. See if you have it active then. You shouldn’t have to run the command from ssh as the systemd template runs those unattended.


#5

It works now. I reinstalled and did a reboot and refreshed from dashboard.

Thank you once again:-)


#6

having the same issue as OP

fresh quickbox install

updated to latest build quickbox 2.4.7

Ubuntu server 16.04 LTS

sd-60675:~# systemctl status [email protected][email protected] - pyLoad
   Loaded: loaded (/etc/systemd/system/[email protected]; enabled)                                                                                                                                                   
   Active: failed (Result: resources) since Mon 2016-09-12 03:50:59 CEST; 48s ago
  Process: 4162 ExecStart=/usr/bin/python /home/seedbox/.pyload/pyLoadCore.py --config=/home/seedbox/.pyload --pidfile=/var/run/pyload/pid --daemon (code=exited, status=0/SUCCESS)                                
                                                                                                                                                                                                                   
Sep 12 03:50:59 sd-60675 python[4162]: Daemon PID 4196                                                                                                                                                             
Sep 12 03:50:59 sd-60675 systemd[1]: [email protected] never wrote its PID file. Failing.                                                                                                                     
Sep 12 03:50:59 sd-60675 systemd[1]: Failed to start pyLoad.
Sep 12 03:50:59 sd-60675 systemd[1]: Unit [email protected] entered failed state.                                                                                                                             

when attempting to restart service via systemctl restart pyload getting the same error as op

i have also run setup-pyload but same issue will attempt a reinstall and reboot like OP did and post findings

EDIT: reinstalled ran setup-pyload restarted service and now its working… seems to not work on first install for some strange reason


#7

I had noticed this on a couple of instances recently. On one server it installed just fine… then on another it had to be installed/uninstalled/installed to stick. Not quite sure, but now that I am back in the saddle I will give this an in depth look.


#8

“setup-pyload” wont work, did a few re-installs any idea?

“[[email protected]]:(0b)~$ disktest
16384+0 records in
16384+0 records out
1073741824 bytes (1.1 GB, 1.0 GiB) copied, 6.61866 s, 162 MB/s
[[email protected]]:(0b)~$ setup-pyload
-bash: ssetup-pyload: command not found
[[email protected]]:(0b)~$ setup-pyload
-bash: setup-pyload: command not found
[[email protected]]:(0b)~$”


#9

It’s a system command that requires to be ran as root. So, try to run as sudo or… as our readme recommends… root user. You can get to root by typing sudo su

Also, please post a new topic for questions and try to avoid reviving old solved topics.


#10