Pyload Issue : can't find pyLoadCore.py

pyload

#1

I am facing the same problem as in :

When in root, I do the following but it returns an error message :

bt:/# setup-pyLoad
/usr/bin/python: can’t open file ‘/home/username/.pyload/pyLoadCore.py’: [Errno 2] No such file or directory
bt:/home/username/.pyload#

I’ve installed/restalled pyLoad like 8 times but to no avail.

Thank you for your help on this matter and sorry if I’ve missed a solution somewhere in the forum.


#2

When I get back to my computer in a couple of hours I will run a couple of tests locally. I remember this being a problem. I’ll work to sort this one out.


#3

Great, thanks a lot @JMSolo


#4

I ran a few tests and it looks like it is installing properly. What commit are you currently on? It should show on the update widget.


#5

It’s running QB v2.4.9


#6

Ah, yeah, you’re a bit out-dated. The current version is v2.5.1. Could you run box upgrade from shell and see if that sorts out your issues. A lot was patched since your current version. If you have any difficulties just let me know and I will handle it for you (if that’s an option for you) :wink:


#7

Here’s the list of updated files:
inc/config.php
24,895 100% 0.00kB/s 0:00:00 (xfr#1, to-chk=369/420)
inc/localize.php
310 100% 60.55kB/s 0:00:00 (xfr#2, to-chk=368/420)
widgets/bw_tables.php
6,548 100% 456.75kB/s 0:00:00 (xfr#3, to-chk=13/420)
widgets/data.php
1,283 100% 83.53kB/s 0:00:00 (xfr#4, to-chk=10/420)
widgets/stat.php
340 100% 22.14kB/s 0:00:00 (xfr#5, to-chk=3/420)

That’s not much but I’ll try to reinstall pyLoad again


#8

Did your version update to v2.5.1? There is a lot more than that, probably just what it’s spitting out there. Assuming you’re on the proper repository. :thinking:


#9

No, it did not

2017-09-01_16-13-05

EDIT: I’ll follow these steps : https://quickbox.io/qb-source-code-is-moving-to-github/


#10

Ok, I think you’re on the QuickBox/QuickBox repo and not the QuickBox/QB repo. (crazy, I know). Check to see if there is an QuickBox directory in your /root/ location. If there is, do rm -rf /root/QuickBox. Then, just for good measure run the following rm -rf /etc/QuickBox. Now grab the proper repo and update the proper commands with the details below:

git clone https://github.com/QuickBox/QB /etc/QuickBox; \
wget -O /usr/local/bin/quickbox/system/updateQuickBox https://raw.githubusercontent.com/QuickBox/QB/master/packages/system/updateQuickBox; \
dos2unix $(find /usr/local/bin/quickbox -type f) && chmod +x $(find /usr/local/bin/quickbox -type f); \
updateQuickBox

#11

Ok, I followed the above steps and now my QB is 2.5.1

pyLoad is installing properly, however, I get a 503 error message. I’ve chosen the threaded version during the install


#12

Let me give that one a quick test. I’ll post back shortly.

Update

Can confirm, seems threaded is borked. I’ll dig further in on this today. Thanks for spotting that. :+1:


#13

Great, thank you very much for your help @JMSolo , as usual I must say :smiley:


#14

@JMSolo do you think I am the only concerned by this error if it’s a scripting problem ?


#15

No, I don’t think you’re the only one concerned about this issue. I noticed it trying to perform the install with anything other than local. I am still not sure of the cause, but I do promise, once I have the time to dig into it, I will.