Proxy Error for Sonarr


#1

So, I’m brand new to dealing with linux, so still a lot to learn.

I got QuickBox on my server, logged into the dashboard, and installed Sonarr successfully.

The issue is when I click on Sonarr it gives me a Proxy Error:

"Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /sonarr.

Reason: DNS lookup failure for: localhost"

So I’m lost here as to what to do to be able to access Sonarr (same issue for SABnzbd)


#2

…Anyone??


#3

Hello,

Could you please show us the return of this command please?

cat /etc/hosts (if error please use sudo)


#4

This is what was returned:

127.0.0.1 mydomain.com


#5

Could you please try ping localhost and tell us the result?


#6

This is the result:

ping: unknown host localhost


#7

Okay so modify your /etc/hosts file (sudo nano /etc/hosts) and add this line : 127.0.0.1 localhost

Retry to ping localhost and try to access Sonarr again.


#8

Okay, that seems to have done the trick!

I added the line “127.0.0.1 local host” directly under the line “127.0.0.1 mydomain.com

I did the “ping localhost” and it seemed to keep continually pinging, I’m not sure if that’s what is supposed to happen, but it kept returning a line

“64 bytes from mydomain.com (127.0.0.1): icmp_seq=117 ttl=64 time=0.036 ms”

with the time different each time.

After that, I rebooted the server, logged into the Quickbox dashboard, tried Sonarr and it worked.


#9

Well done :slight_smile:

:wink:


#10

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.