Problem with finding .startup on install and cannot save rutorrent settings

ubuntu
16.04
install

#1

Trying to install quickbox on Ubuntu 16.04 x64 on Hyper-V but in the end I am getting an error saying there is no ".startup’: No such file or directory "

Installing on a fresh install using sudo -i to become root w/ a username already made.

These are the problems I am facing after the install:

  1. rutorrent seems to run fine but I cannot save any of the settings like download location or port number.

  2. Cant read disk space, getting: You have used NaN% of your total disk space. When I installed quota I set it to read /home because I have my windows folders mounted there using nfs to auto mount on startup using /etc/fstab .

Any help would be appreciated.
Thanks

Setting up quotas for /(home) mount … [ DONE ]
Setting up Limited Shell environment … [ DONE ]
Building ffmpeg from source for screenshots … [ DONE ]
Installing xmlrpc-c-1.33.12 … [ DONE ]
Installing libtorrent-0.13.6 … [ DONE ]
Installing rtorrent-0.9.6 … [ DONE ]
Installing rutorrent into /srv … [ DONE ]
Installing rutorrent plugins … [ DONE ]
Installing deluge … [ DONE ]
Installing quickbox dashboard … [ DONE ]
Setting up seedbox.conf for apache … [ DONE ]
Installing .rtorrent.rc for nat … [ DONE ]
Adjusting fileupload & filemanager plugins … [ DONE ]
Installing autodl-irssi … [ DONE ]
Making nat directory structure … [ DONE ]
Writing nat rutorrent config.php file … [ DONE ]
Installing vsftpd … [ DONE ]
Setting up vsftpd … [ DONE ]
Setting irssi/rtorrent to start on boot … [ DONE ]
Setting permissions on nat … [ ] chown: cannot access ‘/home/nat/.startup’: No such file or directory
chmod: cannot access ‘/home/nat/.startup’: No such file or directory [ DONE ]

 [quickbox] Seddbox & GUI Installation Completed
        INSTALLATION COMPLETED in 24/min

#2

Hello @NatPagles,

This is in fact, a leftover sed command. You can safely use QuickBox without issue. The command you see there was from when we used cron heavily… it is no longer used due to QuickBox using systemd.

  1. .startup is a leftover sed command and nothing more, this has no effect on rutorrent nor any of it’s underlying functions. Not sure either why you would want to change your port number in rutorrent.

  2. Pay close attention to the details. You will need to initiate a space allowance to your users. This is exclaimed in the end of the install with the listed commands. Type setdisk to assign any amount of space to a given user.


#3

Hi @JMSolo,

I just tried setdisk but doesn’t seem to work. I am getting this error as root:

setquota: Cannot open quotafile //aquota.user: No such file or directory

and as user I get:

-bash: setdisk: command not found

As for the rtorrent port just wanted to use my old rtorrent port number that was already setup in my router but I can change it there if we cant find a solution to the settings not being saved.

Problem was I couldnt change any of the settings like download location in rutorrent. I tried editing the rtorrent.rc file but rtorrent wouldnt startup after so I reverted it back to defaults.

Edit: Just changed ports in my router and changed mount point to the default rtorrent folder and that did the job but was wondering if not being able to change ports and download location is a bug or was done purposely?

Thanks


#4

I have the same issue with regard to ruTorrent. Any changes I make to settings are lost on the next restart.

Perhaps its a permissions problem?


#5

The port issue is more than likely something happening within ruTorrent itself and would be a question for Novik.
As per the download location, if that changes then the apache configuration we have setup for the downloads directory will also need to be changed. I have known others to change this to something else they desire… so not sure why this would be blocking you… I will need to investigate and attempt to reproduce on a test server.

As per the settings themselves, since @Jason is having the issue as well I will dig into this once I get back form my meeting today. It quite possibly could be permissions related. What’s odd is how they would reset upon restart… as if maybe the settings are recreating themselves (which certainly shouldn’t be happening)

Thanks for the report guys and I will give them some attention very soon. :thumbsup:


#6

The seedbox provider I used to use had both Deluge and ruTorrent pointing to the same directory which I found much more convenient.

Rather than /torrents/deluge and /torrents/rtorrent just a single /torrents/downloads directory.

But of course it depends on how you like to use them, if you use both etc.


#7

We originally had this scheme setup. However, we received a lot of feedback and requests to have these separate due to various small providers offering QuickBox on their setups as well as users (some racers) wanting to have a more organized approach to what’s what. I personally could care less :wink:


#8

This is just how rutorrent and rtorrent works.

If you want the changes to persist between sessions you need to edit the .rtorrent.rc directly

See here


#9

@liara

Thats strange. I wonder why no one has ever wrote a plugin to save and load settings on startup.

I think this is my main issue now with QB (not that any of these things are your guys responsibility). The standard deluge settings are not quite right, in that they start downloading , work up to full speed, then get slower and slower and slower. As if its not handling the cache correctly or the disk cant keep up. This is with torrents with lots of high speed seeders.

If I switch to rutorrent it works up to full speed and stays there (ruling out a hardware issue) But it has annoying “features” like losing its settings and the total seed time. Also a force recheck takes forever.

In retrospect, I wish I had saved the config settings from Seedhost, Seedboxes, Feral etc etc to compare. I wonder if we could talk someone who still has a live box to share their settings :slight_smile:


#10

This is what ltConfig is for and we push it by default now albeit purposefully unconfigured.

Deluge is used commonly on both desktops and high performance servers. Both requires very different settings to perform at maximum potential. It just so happens that deluge defaults to the average user rather than high performance.

The high performance preset in ltconfig is a great starting point but it is not perfect.