Plugin couchpotato (add a new provider)


#1

Hi, I’m trying to add a new provider to Couchpotato with a plugin.

this one : https://github.com/djoole/couchpotato.provider.t411

So when I check the directory in couchpotato, there is this :

Directories
/home/noodles/.couchpotato
/home/noodles/.couchpotato

But if I put the t411 folder into /home/noodles/.couchpotato/customs_plugin folder, it doesn’t work, even if I restart couchpotato.
I also tried with another provider, same results.
Am I doing something wrong?

Thanks.


#2

yeah, try the existing custom_plugin folder(without the s) and restart couchpotato. It worked for me:


#3

Sorry, typo ! It’s home/noodles/.couchpotato/custom_plugins

When I rename it, a new folder “custom_plugins” is created when CP restart.

And still no sign of it in CP


#4

I dont know what to say other than “it works for me”.
Mine is /home/user/.couchpotato/custom_plugins/t411


#5

I just removed and installed it again, and now it works fine.
Thank you


#6

Hi :slight_smile:
T411 has changed its extension.
This repo has updated the T411’s couchpotato files : https://github.com/Snipees/couchpotato.providers.french
And by the way it adds the french providers cpasbien :wink: